aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorVladimír Čunát <v@cunat.cz>2020-10-25 22:17:24 +0100
committerVladimír Čunát <v@cunat.cz>2020-10-26 09:01:04 +0100
commit89023c38fcef79ad135bf6070563be611c4c8d39 (patch)
tree48453a80001a7907890520f458b7c50aec598da8 /pkgs/stdenv
parent4bd836b381c474893747f9051cfac93d94d13786 (diff)
Recover the complicated situation after my bad merge
I made a mistake merge. Reverting it in c778945806b undid the state on master, but now I realize it crippled the git merge mechanism. As the merge contained a mix of commits from `master..staging-next` and other commits from `staging-next..staging`, it got the `staging-next` branch into a state that was difficult to recover. I reconstructed the "desired" state of staging-next tree by: - checking out the last commit of the problematic range: 4effe769e2b - `git rebase -i --preserve-merges a8a018ddc0` - dropping the mistaken merge commit and its revert from that range (while keeping reapplication from 4effe769e2) - merging the last unaffected staging-next commit (803ca85c209) - fortunately no other commits have been pushed to staging-next yet - applying a diff on staging-next to get it into that state
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index a040e6ab2424..58da8b71b650 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -190,10 +190,7 @@ in rec {
stage1 = prevStage: let
persistent = self: super: with prevStage; {
- cmake = super.cmake.override {
- isBootstrap = true;
- useSharedLibraries = false;
- };
+ cmake = super.cmakeMinimal;
python3 = super.python3Minimal;