aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2020-12-02 15:37:31 +0100
committerFrederik Rietdijk <freddyrietdijk@fridh.nl>2020-12-02 20:32:38 +0100
commit1649296354b32f551dc8742cf845e73d8940be7a (patch)
tree34b21c10ffa54228f96909f24aeb2cf83a2f2181 /pkgs/stdenv
parent16a36e48bd8bd9921fb3b5b549aa10b863409ec3 (diff)
makeBootstrapTools: set schedulingPriority
Increase schedulingPriority of the bootstrap tools to unblock the nixpkgs-unstable channel. The channel is repeatedly blocked by the makeBootstrapTools job for aarch64. The cause is lack of resources. By increasing the priority, it should become the first job Hydra would build, allowing the channel to advance quicker. Of course, it does mean that while the channel advances, nothing else has been built. This should be a temporary solution until we have more capacity for aarch64.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/make-bootstrap-tools.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/stdenv/linux/make-bootstrap-tools.nix b/pkgs/stdenv/linux/make-bootstrap-tools.nix
index 421bb8502a4c..25cde589a923 100644
--- a/pkgs/stdenv/linux/make-bootstrap-tools.nix
+++ b/pkgs/stdenv/linux/make-bootstrap-tools.nix
@@ -47,6 +47,12 @@ in with pkgs; rec {
stdenv.mkDerivation {
name = "stdenv-bootstrap-tools";
+ meta = {
+ # Increase priority to unblock nixpkgs-unstable
+ # https://github.com/NixOS/nixpkgs/pull/104679#issuecomment-732267288
+ schedulingPriority = 200;
+ };
+
nativeBuildInputs = [ buildPackages.nukeReferences buildPackages.cpio ];
buildCommand = ''
@@ -199,6 +205,12 @@ in with pkgs; rec {
dist = stdenv.mkDerivation {
name = "stdenv-bootstrap-tools";
+ meta = {
+ # Increase priority to unblock nixpkgs-unstable
+ # https://github.com/NixOS/nixpkgs/pull/104679#issuecomment-732267288
+ schedulingPriority = 200;
+ };
+
buildCommand = ''
mkdir -p $out/nix-support
echo "file tarball ${build}/on-server/bootstrap-tools.tar.xz" >> $out/nix-support/hydra-build-products