aboutsummaryrefslogtreecommitdiff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-10-01 04:20:00 +0000
committerMario Rodas <marsam@users.noreply.github.com>2020-10-01 04:20:00 +0000
commitf31108fa22bbce80e91ed3efc23c5cd6cb40107d (patch)
tree5597af8b2f8fc06aedc199f67e6a6d58331db7d5 /pkgs/shells
parent582f5cea5fa217891a4b999e776ed6fca43aebb5 (diff)
nushell: 0.19.0 -> 0.20.0
https://www.nushell.sh/blog/2020/09/22/nushell_0_20.html
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/nushell/default.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/pkgs/shells/nushell/default.nix b/pkgs/shells/nushell/default.nix
index 09d2f6aac1a5..628c61db329f 100644
--- a/pkgs/shells/nushell/default.nix
+++ b/pkgs/shells/nushell/default.nix
@@ -3,6 +3,7 @@
, fetchFromGitHub
, rustPlatform
, openssl
+, zlib
, pkg-config
, python3
, xorg
@@ -14,35 +15,36 @@
rustPlatform.buildRustPackage rec {
pname = "nushell";
- version = "0.19.0";
+ version = "0.20.0";
src = fetchFromGitHub {
owner = pname;
repo = pname;
rev = version;
- sha256 = "08r6f71cy4j22k0mllm134x4dfixaircpaz5arrj93xsbp38nk92";
+ sha256 = "038c61605b92a97h84hlifwks0q6miv6rn7spr5h6h2nwvaqlyk6";
};
- cargoSha256 = "15kvl490abxdv6706zs7pv0q5fhghmdvlfbn19037sldkcsfl86b";
+ cargoSha256 = "1vr0pqcv9gm4cwlkd06672jzz9rbm77c6j5r05waypc1lv4ln2cg";
nativeBuildInputs = [ pkg-config ]
++ lib.optionals (withStableFeatures && stdenv.isLinux) [ python3 ];
- buildInputs = lib.optionals stdenv.isLinux [ openssl ]
- ++ lib.optionals stdenv.isDarwin [ libiconv Security ]
+ buildInputs = [ openssl ]
+ ++ lib.optionals stdenv.isDarwin [ zlib libiconv Security ]
++ lib.optionals (withStableFeatures && stdenv.isLinux) [ xorg.libX11 ]
++ lib.optionals (withStableFeatures && stdenv.isDarwin) [ AppKit ];
cargoBuildFlags = lib.optional withStableFeatures "--features stable";
- preCheck = ''
- export HOME=$TMPDIR
+ # Remove after https://github.com/NixOS/nixpkgs/pull/97000 lands into master
+ preConfigure = stdenv.lib.optionalString stdenv.isDarwin ''
+ unset SDKROOT
'';
checkPhase = ''
runHook preCheck
echo "Running cargo test"
- cargo test
+ HOME=$TMPDIR cargo test
runHook postCheck
'';