aboutsummaryrefslogtreecommitdiff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorTim Steinbach <NeQuissimus@users.noreply.github.com>2020-11-05 07:28:24 -0500
committerGitHub <noreply@github.com>2020-11-05 07:28:24 -0500
commit3a6feb7ec7a3917219034aa5dc1dbcdcb5d3f059 (patch)
tree76f32bac00cd6f07414ec084058261539926215b /pkgs/shells
parent51f2519a68b505cfc13be23052c4375cb1c62f90 (diff)
parent9813539969d6071ed1a162a1d45d7521b2980c2a (diff)
Merge pull request #102850 from NeQuissimus/oh-my-zsh_update
oh-my-zsh: Update script, test
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/oh-my-zsh/default.nix41
-rwxr-xr-xpkgs/shells/zsh/oh-my-zsh/update.sh19
2 files changed, 39 insertions, 21 deletions
diff --git a/pkgs/shells/zsh/oh-my-zsh/default.nix b/pkgs/shells/zsh/oh-my-zsh/default.nix
index e7433e2de0b8..3660453245bb 100644
--- a/pkgs/shells/zsh/oh-my-zsh/default.nix
+++ b/pkgs/shells/zsh/oh-my-zsh/default.nix
@@ -1,7 +1,8 @@
# This script was inspired by the ArchLinux User Repository package:
#
# https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=oh-my-zsh-git
-{ stdenv, fetchFromGitHub }:
+{ stdenv, fetchFromGitHub, nixosTests, writeScript, common-updater-scripts, git
+, nix, nixfmt, jq, coreutils, gnused, curl, cacert }:
stdenv.mkDerivation rec {
version = "2020-10-29";
@@ -12,7 +13,7 @@ stdenv.mkDerivation rec {
inherit rev;
owner = "ohmyzsh";
repo = "ohmyzsh";
- sha256 = "0021rayw5wiwgjfwy7d6g577xidws58vk7y9xxhidnmk9sr4vri7";
+ sha256 = "J+ZNsk6z2hZh78mfuVHRvMV+TnmmHc+dfDzywr3KQQA=";
};
installPhase = ''
@@ -65,6 +66,42 @@ stdenv.mkDerivation rec {
EOF
'';
+ passthru = {
+ tests = { inherit (nixosTests) oh-my-zsh; };
+
+ updateScript = writeScript "update.sh" ''
+ #!${stdenv.shell}
+ set -o errexit
+ PATH=${
+ stdenv.lib.makeBinPath [
+ common-updater-scripts
+ curl
+ cacert
+ git
+ nixfmt
+ nix
+ jq
+ coreutils
+ gnused
+ ]
+ }
+
+ oldVersion="$(nix-instantiate --eval -E "with import ./. {}; lib.getVersion oh-my-zsh" | tr -d '"')"
+ latestSha="$(curl -L -s https://api.github.com/repos/ohmyzsh/ohmyzsh/commits\?sha\=master\&since\=$oldVersion | jq -r '.[0].sha')"
+
+ if [ ! "null" = "$latestSha" ]; then
+ nixpkgs="$(git rev-parse --show-toplevel)"
+ default_nix="$nixpkgs/pkgs/shells/zsh/oh-my-zsh/default.nix"
+ latestDate="$(curl -L -s https://api.github.com/repos/ohmyzsh/ohmyzsh/commits/$latestSha | jq '.commit.author.date' | sed 's|"\(.*\)T.*|\1|g')"
+ update-source-version oh-my-zsh "$latestSha" --version-key=rev
+ update-source-version oh-my-zsh "$latestDate" --ignore-same-hash
+ nixfmt "$default_nix"
+ else
+ echo "${pname} is already up-to-date"
+ fi
+ '';
+ };
+
meta = with stdenv.lib; {
description = "A framework for managing your zsh configuration";
longDescription = ''
diff --git a/pkgs/shells/zsh/oh-my-zsh/update.sh b/pkgs/shells/zsh/oh-my-zsh/update.sh
deleted file mode 100755
index 738c0810737a..000000000000
--- a/pkgs/shells/zsh/oh-my-zsh/update.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env nix-shell
-#!nix-shell -i bash -p curl common-updater-scripts jq
-
-set -eu -o pipefail
-
-oldVersion="$(nix-instantiate --eval -E "with import ./. {}; lib.getVersion oh-my-zsh" | tr -d '"')"
-latestSha="$(curl -L -s https://api.github.com/repos/ohmyzsh/ohmyzsh/commits\?sha\=master\&since\=${oldVersion} | jq -r '.[0].sha')"
-
-if [ ! "null" = "${latestSha}" ]; then
- latestDate="$(curl -L -s https://api.github.com/repos/ohmyzsh/ohmyzsh/commits/${latestSha} | jq '.commit.author.date' | sed 's|"\(.*\)T.*|\1|g')"
- update-source-version oh-my-zsh "${latestSha}" --version-key=rev
- update-source-version oh-my-zsh "${latestDate}" --ignore-same-hash
- nixpkgs="$(git rev-parse --show-toplevel)"
- default_nix="$nixpkgs/pkgs/shells/zsh/oh-my-zsh/default.nix"
- git add "${default_nix}"
- git commit -m "oh-my-zsh: ${oldVersion} -> ${latestDate}"
-else
- echo "oh-my-zsh is already up-to-date"
-fi