aboutsummaryrefslogtreecommitdiff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2020-11-30 22:16:14 +0100
committerMaximilian Bosch <maximilian@mbosch.me>2020-11-30 23:00:18 +0100
commitc55af95e8fe70e14833cfb1e34310db1b91cc887 (patch)
tree349a8d2c70758d78eb37baba79b281f20de72603 /pkgs/servers
parent51e63b550d7ff29c6760e8025dbc7dee64091f0c (diff)
gotify-server: fix UI delivery
After bisecting `nixpkgs-master` I realized that the usage of `-trimpath`[0] by default for Go modules[1] is responsible for breaking UI delivery of `gotify-server`[2]. This behavior can only be turned off by setting `allowGoReference` to `true`. We may want to find a better long-term fix, but given that this only affects a leaf-package and actually fixes the problem, this is good enough for now. Fixes #105472 [0] https://golang.org/doc/go1.13#go-command [1] 4e9f7bbf8573d07f7b0c87d97c026cd4aad5a758 [2] https://hydra.nixos.org/build/131660876
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/gotify/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/servers/gotify/default.nix b/pkgs/servers/gotify/default.nix
index 924625ebd783..a7fb1d0e7e57 100644
--- a/pkgs/servers/gotify/default.nix
+++ b/pkgs/servers/gotify/default.nix
@@ -20,6 +20,12 @@ buildGoModule rec {
sha256 = import ./source-sha.nix;
};
+ # With `allowGoReference = true;`, `buildGoModule` adds the `-trimpath`
+ # argument for Go builds which apparently breaks the UI like this:
+ #
+ # server[780]: stat /var/lib/private/ui/build/index.html: no such file or directory
+ allowGoReference = true;
+
vendorSha256 = import ./vendor-sha.nix;
doCheck = false;