aboutsummaryrefslogtreecommitdiff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2020-11-28 08:53:47 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2020-11-28 08:53:47 +0100
commit9e062723b2d60d2be85268fb7eebb28abce0b5af (patch)
tree691e8a0b8cb475751f75f192dd3e16f452c6fcce /pkgs/servers
parentb2a3891e12777fa5e16bc93bc95c0d5ba256ebaf (diff)
parent8256fc2da56b573411144030c48812c12798676b (diff)
Merge master into staging-next
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/etcd/3.4.nix4
-rw-r--r--pkgs/servers/http/nginx/mainline.nix4
-rw-r--r--pkgs/servers/rainloop/default.nix25
-rw-r--r--pkgs/servers/ursadb/default.nix1
4 files changed, 19 insertions, 15 deletions
diff --git a/pkgs/servers/etcd/3.4.nix b/pkgs/servers/etcd/3.4.nix
index be52b1bf1a58..dc9fc0898dff 100644
--- a/pkgs/servers/etcd/3.4.nix
+++ b/pkgs/servers/etcd/3.4.nix
@@ -2,7 +2,7 @@
buildGoModule rec {
pname = "etcd";
- version = "3.4.13";
+ version = "3.4.14";
deleteVendor = true;
vendorSha256 = "0jlnh4789xa2dhbyp33k9r278kc588ykggamnnfqivb27s2646bc";
@@ -13,7 +13,7 @@ buildGoModule rec {
owner = "etcd-io";
repo = "etcd";
rev = "v${version}";
- sha256 = "0bvky593241i60qf6793sxzsxwfl3f56cgscnva9f2jfhk157wmy";
+ sha256 = "0s6xwc8yczjdf6xysb6m0pp31hxjqdqjw24bliq08094jprhj31f";
};
buildPhase = ''
diff --git a/pkgs/servers/http/nginx/mainline.nix b/pkgs/servers/http/nginx/mainline.nix
index 7b7de1a00f4a..edb87258d6b7 100644
--- a/pkgs/servers/http/nginx/mainline.nix
+++ b/pkgs/servers/http/nginx/mainline.nix
@@ -1,6 +1,6 @@
{ callPackage, ... }@args:
callPackage ./generic.nix args {
- version = "1.19.4";
- sha256 = "03h0hhrbfy3asla9gki2cp97zjn7idxbp5lk9xi0snlh4xlm9pv1";
+ version = "1.19.5";
+ sha256 = "173rv8gacd9bakb0r9jmkr4pqgjw9mzpdh3f7x2d8ln4ssplc2jw";
}
diff --git a/pkgs/servers/rainloop/default.nix b/pkgs/servers/rainloop/default.nix
index bff5d2ea3062..42c68d5608ed 100644
--- a/pkgs/servers/rainloop/default.nix
+++ b/pkgs/servers/rainloop/default.nix
@@ -24,7 +24,8 @@
*/
function __get_custom_data_full_path()
{
- return '${dataPath}'; // custom data folder path
+ $v = getenv('RAINLOOP_DATA_DIR', TRUE);
+ return $v === FALSE ? '${dataPath}' : $v;
}
'';
@@ -33,6 +34,8 @@
cp -r rainloop/* $out
rm -rf $out/data
cp ${includeScript} $out/include.php
+ mkdir $out/data
+ chmod 700 $out/data
'';
meta = with stdenv.lib; {
@@ -44,13 +47,13 @@
maintainers = with maintainers; [ das_j ];
};
});
- in {
- rainloop-community = common {
- edition = "community";
- sha256 = "0a8qafm4khwj8cnaiaxvjb9073w6fr63vk1b89nks4hmfv10jn6y";
- };
- rainloop-standard = common {
- edition = "";
- sha256 = "0961g4mci080f7y98zx9r4qw620l4z3na1ivvlyhhr1v4dywqvch";
- };
- }
+in {
+ rainloop-community = common {
+ edition = "community";
+ sha256 = "0a8qafm4khwj8cnaiaxvjb9073w6fr63vk1b89nks4hmfv10jn6y";
+ };
+ rainloop-standard = common {
+ edition = "";
+ sha256 = "0961g4mci080f7y98zx9r4qw620l4z3na1ivvlyhhr1v4dywqvch";
+ };
+}
diff --git a/pkgs/servers/ursadb/default.nix b/pkgs/servers/ursadb/default.nix
index 8a2f768443f5..6a3a1cff5b56 100644
--- a/pkgs/servers/ursadb/default.nix
+++ b/pkgs/servers/ursadb/default.nix
@@ -31,5 +31,6 @@ stdenv.mkDerivation {
license = licenses.bsd3;
maintainers = with maintainers; [ msm ];
platforms = platforms.unix;
+ broken = stdenv.isDarwin;
};
}