aboutsummaryrefslogtreecommitdiff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2020-12-02 12:30:55 +0000
committerGitHub <noreply@github.com>2020-12-02 12:30:55 +0000
commit89e8bf0f2a0bb9c4cbf4544320d2241264e99bdc (patch)
treebbb1264d6436d4cd09dac70dfa6d2f153ca9a3a7 /pkgs/servers
parent023dafc6b80532fa2df4c50d5fdcb987f00992e0 (diff)
parente313c7d219fd93cfda926803425ec430c3dcfe66 (diff)
Merge master into staging-next
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/gitlab-pages/default.nix6
-rw-r--r--pkgs/servers/http/openresty/default.nix18
-rw-r--r--pkgs/servers/pinnwand/default.nix2
3 files changed, 15 insertions, 11 deletions
diff --git a/pkgs/servers/http/gitlab-pages/default.nix b/pkgs/servers/http/gitlab-pages/default.nix
index bef6744d1312..0174f8af43f5 100644
--- a/pkgs/servers/http/gitlab-pages/default.nix
+++ b/pkgs/servers/http/gitlab-pages/default.nix
@@ -2,16 +2,16 @@
buildGoModule rec {
pname = "gitlab-pages";
- version = "1.28.0";
+ version = "1.30.0";
src = fetchFromGitLab {
owner = "gitlab-org";
repo = "gitlab-pages";
rev = "v${version}";
- sha256 = "15q32blkhmc5w1b2xh45y7cag8f6bw9bgiwin5ykrzj5d305wd16";
+ sha256 = "0gn5lwn1lk1ghv6lw0fvax0m829w09mmq8flbmcxvszfyv7x0rix";
};
- vendorSha256 = "1gzkb2j2hl6ln8i5wjk2n9g8agpdzy1pzghb4sy1r8pdfp0i28r3";
+ vendorSha256 = "08zma4b58b9132h41m6frbdi502yima9lkpab87fi0q5r6qwhf1z";
subPackages = [ "." ];
doCheck = false; # Broken
diff --git a/pkgs/servers/http/openresty/default.nix b/pkgs/servers/http/openresty/default.nix
index 734dfb041403..964517649900 100644
--- a/pkgs/servers/http/openresty/default.nix
+++ b/pkgs/servers/http/openresty/default.nix
@@ -8,15 +8,19 @@
callPackage ../nginx/generic.nix args rec {
pname = "openresty";
- nginxVersion = "1.17.8";
- version = "${nginxVersion}.2";
+ nginxVersion = "1.19.3";
+ version = "${nginxVersion}.1";
src = fetchurl {
url = "https://openresty.org/download/openresty-${version}.tar.gz";
- sha256 = "1813w33hjm1hcqvl3b3f67qgi5zfjiqg6s01hiy12a5j3jqilcig";
+ sha256 = "0p9xn0xgbk6nmjfb25a3d6bwxm8q23igkixqma5fpygla6fcsvzk";
};
- fixPatch = patch: let name = patch.name or (builtins.baseNameOf patch); in
+ # generic.nix applies fixPatch on top of every patch defined there. This
+ # allows updating the patch destination, as openresty has nginx source code
+ # in a different folder.
+ fixPatch = patch:
+ let name = patch.name or (builtins.baseNameOf patch); in
runCommand "openresty-${name}" { src = patch; } ''
substitute $src $out \
--replace "a/" "a/bundle/nginx-${nginxVersion}/" \
@@ -40,9 +44,9 @@ callPackage ../nginx/generic.nix args rec {
meta = {
description = "A fast web application server built on Nginx";
- homepage = "http://openresty.org";
- license = lib.licenses.bsd2;
- platforms = lib.platforms.all;
+ homepage = "http://openresty.org";
+ license = lib.licenses.bsd2;
+ platforms = lib.platforms.all;
maintainers = with lib.maintainers; [ thoughtpolice lblasc emily ];
};
}
diff --git a/pkgs/servers/pinnwand/default.nix b/pkgs/servers/pinnwand/default.nix
index 16fa6a7196ab..fd02fc770813 100644
--- a/pkgs/servers/pinnwand/default.nix
+++ b/pkgs/servers/pinnwand/default.nix
@@ -1,4 +1,4 @@
-{ lib, python3, fetchFromGitHub, poetry, nixosTests }:
+{ lib, python3, fetchFromGitHub, nixosTests }:
let
python = python3.override {