aboutsummaryrefslogtreecommitdiff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMichael Raitza <michael.raitza@tu-dresden.de>2020-10-02 12:12:26 +0200
committerJörg Thalheim <joerg@thalheim.io>2020-11-17 16:12:22 +0100
commit54a69eb80480016341d4825f272b9017a3bd0ac1 (patch)
treea7e53311e0998b2e3040a2722408104add497173 /pkgs/servers
parentf08099d0a724bee7123eebea81914c32610f967f (diff)
openafs_1_8: Properly generate and split off developer documentation
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/openafs/1.8/default.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/pkgs/servers/openafs/1.8/default.nix b/pkgs/servers/openafs/1.8/default.nix
index 2247afbc0d95..c26f8d3a23c5 100644
--- a/pkgs/servers/openafs/1.8/default.nix
+++ b/pkgs/servers/openafs/1.8/default.nix
@@ -1,6 +1,7 @@
{ stdenv, buildPackages, fetchurl, which, autoconf, automake, flex
, yacc , glibc, perl, kerberos, libxslt, docbook_xsl, file
, docbook_xml_dtd_43, libtool_2
+, withDevdoc ? false, doxygen, dblatex # Extra developer documentation
, ncurses # Extra ncurses utilities. Needed for debugging and monitoring.
, tsmbac ? null # Tivoli Storage Manager Backup Client from IBM
}:
@@ -15,13 +16,13 @@ in stdenv.mkDerivation {
depsBuildBuild = [ buildPackages.stdenv.cc ];
nativeBuildInputs = [ autoconf automake flex libxslt libtool_2 perl
- which yacc ];
+ which yacc ] ++ optionals withDevdoc [ doxygen dblatex ];
buildInputs = [ kerberos ncurses ];
patches = [ ./bosserver.patch ./cross-build.patch ] ++ optional (tsmbac != null) ./tsmbac.patch;
- outputs = [ "out" "dev" "man" "doc" ];
+ outputs = [ "out" "dev" "man" "doc" ] ++ optional withDevdoc "devdoc";
enableParallelBuilding = false;
@@ -69,16 +70,22 @@ in stdenv.mkDerivation {
for d in doc/xml/{AdminGuide,QuickStartUnix,UserGuide}; do
make -C "''${d}" index.html
done
+ '' + optionalString withDevdoc ''
+ make dox
'';
postInstall = ''
mkdir -p $doc/share/doc/openafs/{AdminGuide,QuickStartUnix,UserGuide}
- cp -r doc/{pdf,protocol,txt} README LICENSE $doc/share/doc/openafs
+ cp -r doc/txt README LICENSE $doc/share/doc/openafs
for d in AdminGuide QuickStartUnix UserGuide ; do
cp "doc/xml/''${d}"/*.html "$doc/share/doc/openafs/''${d}"
done
rm -r $out/lib/openafs
+ '' + optionalString withDevdoc ''
+ mkdir -p $devdoc/share/devhelp/openafs/doxygen
+ cp -r doc/{pdf,protocol} $devdoc/share/devhelp/openafs
+ cp -r doc/doxygen/output/html $devdoc/share/devhelp/openafs/doxygen
'';
# Avoid references to $TMPDIR by removing it and let patchelf cleanup the