aboutsummaryrefslogtreecommitdiff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2020-12-02 12:30:55 +0000
committerGitHub <noreply@github.com>2020-12-02 12:30:55 +0000
commit89e8bf0f2a0bb9c4cbf4544320d2241264e99bdc (patch)
treebbb1264d6436d4cd09dac70dfa6d2f153ca9a3a7 /pkgs/os-specific
parent023dafc6b80532fa2df4c50d5fdcb987f00992e0 (diff)
parente313c7d219fd93cfda926803425ec430c3dcfe66 (diff)
Merge master into staging-next
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/firmware/sof-firmware/default.nix14
-rw-r--r--pkgs/os-specific/linux/kernel/linux-testing.nix4
-rw-r--r--pkgs/os-specific/linux/nvidia-x11/default.nix8
-rw-r--r--pkgs/os-specific/linux/zfs/default.nix25
4 files changed, 20 insertions, 31 deletions
diff --git a/pkgs/os-specific/linux/firmware/sof-firmware/default.nix b/pkgs/os-specific/linux/firmware/sof-firmware/default.nix
index a9fc44e48cc8..684d638ce29f 100644
--- a/pkgs/os-specific/linux/firmware/sof-firmware/default.nix
+++ b/pkgs/os-specific/linux/firmware/sof-firmware/default.nix
@@ -3,24 +3,22 @@
with stdenv.lib;
stdenv.mkDerivation rec {
pname = "sof-firmware";
- version = "1.5.1";
+ version = "1.6";
src = fetchFromGitHub {
owner = "thesofproject";
repo = "sof-bin";
- rev = "ae61d2778b0a0f47461a52da0d1f191f651e0763";
- sha256 = "0j6bpwz49skvdvian46valjw4anwlrnkq703n0snkbngmq78prba";
+ rev = "cbdec6963b2c2d58b0080955d3c11b96ff4c92f0";
+ sha256 = "0la2pw1zpv50cywiqcfb00cxqvjc73drxwjchyzi54l508817nxh";
};
phases = [ "unpackPhase" "installPhase" ];
installPhase = ''
- mkdir -p $out/lib/firmware/intel
+ mkdir -p $out/lib/firmware
- sed -i 's/ROOT=.*$/ROOT=$out/g' go.sh
- sed -i 's/VERSION=.*$/VERSION=v${version}/g' go.sh
-
- ./go.sh
+ patchShebangs go.sh
+ ROOT=$out SOF_VERSION=v${version} ./go.sh
'';
meta = with stdenv.lib; {
diff --git a/pkgs/os-specific/linux/kernel/linux-testing.nix b/pkgs/os-specific/linux/kernel/linux-testing.nix
index 50c69deeb073..5bf74ffd377b 100644
--- a/pkgs/os-specific/linux/kernel/linux-testing.nix
+++ b/pkgs/os-specific/linux/kernel/linux-testing.nix
@@ -3,7 +3,7 @@
with stdenv.lib;
buildLinux (args // rec {
- version = "5.10-rc5";
+ version = "5.10-rc6";
extraMeta.branch = "5.10";
# modDirVersion needs to be x.y.z, will always add .0
@@ -11,7 +11,7 @@ buildLinux (args // rec {
src = fetchurl {
url = "https://git.kernel.org/torvalds/t/linux-${version}.tar.gz";
- sha256 = "117yvvzdbf8garx484zdp75qgldj8xhr2sqk6mza6lgv4h7v3f4g";
+ sha256 = "14ykzs98r918sqv7lddlps4r7hza1zgw0x67mmj77cmqiv6d8ffi";
};
# Should the testing kernels ever be built on Hydra?
diff --git a/pkgs/os-specific/linux/nvidia-x11/default.nix b/pkgs/os-specific/linux/nvidia-x11/default.nix
index 5fc60b404d89..b16dd3997f60 100644
--- a/pkgs/os-specific/linux/nvidia-x11/default.nix
+++ b/pkgs/os-specific/linux/nvidia-x11/default.nix
@@ -22,10 +22,10 @@ rec {
# Policy: use the highest stable version as the default (on our master).
stable = if stdenv.hostPlatform.system == "x86_64-linux"
then generic {
- version = "455.38";
- sha256_64bit = "0x6w2kcjm5q9z9l6rkxqabway4qq4h3ynngn36i8ky2dpxc1wzfq";
- settingsSha256 = "1hk4yvbb7xhfwm8jiwq6fj5m7vg3w7yvgglhfyhq7bbrlklfb4hm";
- persistencedSha256 = "00mmazv8sy93jvp60v7p954n250f4q3kxc13l4f8fmi28lgv0844";
+ version = "455.45.01";
+ sha256_64bit = "6tyMfggvZVQPp/aiSdgwn7VG/mIGb0lUcnAdyMEDoVM=";
+ settingsSha256 = "70ABqnO/heCp/5IztpU0Lo7eZd4n4wUoTlp1xIQ3aCc=";
+ persistencedSha256 = "36sM+djZvm77Gle7dcZ5tppgzQkD4IA0FJgCGsdZRI8=";
}
else legacy_390;
diff --git a/pkgs/os-specific/linux/zfs/default.nix b/pkgs/os-specific/linux/zfs/default.nix
index 5406dcf77eba..a83e554b6f0a 100644
--- a/pkgs/os-specific/linux/zfs/default.nix
+++ b/pkgs/os-specific/linux/zfs/default.nix
@@ -49,13 +49,11 @@ let
patchShebangs scripts
# The arrays must remain the same length, so we repeat a flag that is
# already part of the command and therefore has no effect.
- substituteInPlace ./module/${optionalString isUnstable "os/linux/"}zfs/zfs_ctldir.c \
+ substituteInPlace ./module/os/linux/zfs/zfs_ctldir.c \
--replace '"/usr/bin/env", "umount"' '"${util-linux}/bin/umount", "-n"' \
--replace '"/usr/bin/env", "mount"' '"${util-linux}/bin/mount", "-n"'
'' + optionalString buildUser ''
- substituteInPlace ./lib/libzfs/libzfs_mount.c --replace "/bin/umount" "${util-linux}/bin/umount" \
- --replace "/bin/mount" "${util-linux}/bin/mount"
- substituteInPlace ./lib/libshare/${optionalString isUnstable "os/linux/"}nfs.c --replace "/usr/sbin/exportfs" "${
+ substituteInPlace ./lib/libshare/os/linux/nfs.c --replace "/usr/sbin/exportfs" "${
# We don't *need* python support, but we set it like this to minimize closure size:
# If it's disabled by default, no need to enable it, even if we have python enabled
# And if it's enabled by default, only change that if we explicitly disable python to remove python from the closure
@@ -65,7 +63,6 @@ let
substituteInPlace ./config/zfs-build.m4 --replace "\$sysconfdir/init.d" "$out/etc/init.d" \
--replace "/etc/default" "$out/etc/default"
substituteInPlace ./etc/zfs/Makefile.am --replace "\$(sysconfdir)" "$out/etc"
- substituteInPlace ./cmd/zed/Makefile.am --replace "\$(sysconfdir)" "$out/etc"
substituteInPlace ./contrib/initramfs/hooks/Makefile.am \
--replace "/usr/share/initramfs-tools/hooks" "$out/usr/share/initramfs-tools/hooks"
@@ -82,15 +79,10 @@ let
substituteInPlace ./etc/systemd/system/Makefile.am \
--replace '$(DESTDIR)$(systemdunitdir)' "$out"'$(DESTDIR)$(systemdunitdir)'
- ${optionalString isUnstable ''
substituteInPlace ./contrib/initramfs/conf.d/Makefile.am \
--replace "/usr/share/initramfs-tools/conf.d" "$out/usr/share/initramfs-tools/conf.d"
substituteInPlace ./contrib/initramfs/conf-hooks.d/Makefile.am \
--replace "/usr/share/initramfs-tools/conf-hooks.d" "$out/usr/share/initramfs-tools/conf-hooks.d"
- ''}
-
- substituteInPlace ./etc/systemd/system/zfs-share.service.in \
- --replace "/bin/rm " "${coreutils}/bin/rm "
substituteInPlace ./cmd/vdev_id/vdev_id \
--replace "PATH=/bin:/sbin:/usr/bin:/usr/sbin" \
@@ -178,10 +170,10 @@ let
Copy-On-Write filesystem with data integrity detection and repair,
snapshotting, cloning, block devices, deduplication, and more.
'';
- homepage = "https://zfsonlinux.org/";
+ homepage = "https://github.com/openzfs/zfs";
license = licenses.cddl;
platforms = platforms.linux;
- maintainers = with maintainers; [ jcumming wizeman fpletz globin ];
+ maintainers = with maintainers; [ hmenke jcumming jonringer wizeman fpletz globin mic92 ];
};
};
in {
@@ -193,9 +185,9 @@ in {
# incompatibleKernelVersion = "4.20";
# this package should point to the latest release.
- version = "0.8.5";
+ version = "2.0.0";
- sha256 = "0vhd3zs2i83pd59nk0llml4vyk4fc178j6nhg00p6k3f6r0l655b";
+ sha256 = "1kriz6pg8wj98izvjc60wp23lgcp4k3mzhpkgj74np73rzgy6v8r";
};
zfsUnstable = common {
@@ -203,9 +195,8 @@ in {
# incompatibleKernelVersion = "4.19";
# this package should point to a version / git revision compatible with the latest kernel release
- version = "2.0.0-rc6";
+ version = "2.0.0";
- sha256 = "0p027x9hsawniwa9h3yayfbcx010anwcfy45rqgkg2r91zr2nfvw";
- isUnstable = true;
+ sha256 = "1kriz6pg8wj98izvjc60wp23lgcp4k3mzhpkgj74np73rzgy6v8r";
};
}