aboutsummaryrefslogtreecommitdiff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorKyle Ondy <kyle@ondy.org>2020-08-12 15:41:24 -0400
committerKyle Ondy <kyle@ondy.org>2020-11-24 00:06:59 -0500
commitb6340e5030cd70f3567014ccc748fa35cedb6e6d (patch)
tree8b49921bf7ab40733458345d0135e738e3da7e09 /pkgs/misc
parentef052cf639319ccc9e95d33a3f4cbf61b021f7a1 (diff)
tmuxPlugins.tmux-fzf: init at unstable-2020-11-12
This plugin has no releases or tags yet, so pinned to the current head of master as of this commit.
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/tmux-plugins/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/misc/tmux-plugins/default.nix b/pkgs/misc/tmux-plugins/default.nix
index d47ab09e3c56..1a14c842c833 100644
--- a/pkgs/misc/tmux-plugins/default.nix
+++ b/pkgs/misc/tmux-plugins/default.nix
@@ -377,6 +377,41 @@ in rec {
};
};
+ tmux-fzf = mkDerivation {
+ pluginName = "tmux-fzf";
+ version = "unstable-2020-11-23";
+ src = fetchFromGitHub {
+ owner = "sainnhe";
+ repo = "tmux-fzf";
+ rev = "312685b2a7747b61f1f4a96bd807819f1450479d";
+ sha256 = "1z0zmsf8asxs9wbwvkiyd81h93wb2ikl8nxxc26sdpi6l333q5s9";
+ };
+ postInstall = ''
+ find $target -type f -print0 | xargs -0 sed -i -e 's|fzf |${pkgs.fzf}/bin/fzf |g'
+ find $target -type f -print0 | xargs -0 sed -i -e 's|sed |${pkgs.gnused}/bin/sed |g'
+ find $target -type f -print0 | xargs -0 sed -i -e 's|tput |${pkgs.ncurses}/bin/tput |g'
+ '';
+ meta = {
+ homepage = "https://github.com/sainnhe/tmux-fzf";
+ description = "Use fzf to manage your tmux work environment! ";
+ longDescription =
+ ''
+ Features:
+ * Manage sessions (attach, detach*, rename, kill*).
+ * Manage windows (switch, link, move, swap, rename, kill*).
+ * Manage panes (switch, break, join*, swap, layout, kill*, resize).
+ * Multiple selection (support for actions marked by *).
+ * Search commands and append to command prompt.
+ * Search key bindings and execute.
+ * User menu.
+ * Popup window support.
+ '';
+ license = stdenv.lib.licenses.mit;
+ platforms = stdenv.lib.platforms.unix;
+ maintainers = with stdenv.lib.maintainers; [ kyleondy ];
+ };
+ };
+
urlview = mkDerivation {
pluginName = "urlview";
version = "unstable-2016-01-06";