aboutsummaryrefslogtreecommitdiff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorSilvan Mosberger <contact@infinisil.com>2020-12-02 22:52:15 +0100
committerGitHub <noreply@github.com>2020-12-02 22:52:15 +0100
commitaeadbb8625ba0aada5bb8c737b14af12e566d537 (patch)
treeb5fed705004aa99bdf955d36c535e5e50e4ba69c /pkgs/misc
parent222966a7d1786923b54c5c520adfc97773e7314f (diff)
parent242fa79ae7bb77cfb0be6113e67ed06e95a83579 (diff)
Merge pull request #95275 from KyleOndy/add_tmux_plugin_fzf
tmuxPlugins.tmux-fzf: init at unstable-2020-11-12
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/tmux-plugins/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/misc/tmux-plugins/default.nix b/pkgs/misc/tmux-plugins/default.nix
index 59f649f939ca..28ac5e6f91f5 100644
--- a/pkgs/misc/tmux-plugins/default.nix
+++ b/pkgs/misc/tmux-plugins/default.nix
@@ -445,6 +445,41 @@ in rec {
};
};
+ tmux-fzf = mkDerivation {
+ pluginName = "tmux-fzf";
+ version = "unstable-2020-11-23";
+ src = fetchFromGitHub {
+ owner = "sainnhe";
+ repo = "tmux-fzf";
+ rev = "312685b2a7747b61f1f4a96bd807819f1450479d";
+ sha256 = "1z0zmsf8asxs9wbwvkiyd81h93wb2ikl8nxxc26sdpi6l333q5s9";
+ };
+ postInstall = ''
+ find $target -type f -print0 | xargs -0 sed -i -e 's|fzf |${pkgs.fzf}/bin/fzf |g'
+ find $target -type f -print0 | xargs -0 sed -i -e 's|sed |${pkgs.gnused}/bin/sed |g'
+ find $target -type f -print0 | xargs -0 sed -i -e 's|tput |${pkgs.ncurses}/bin/tput |g'
+ '';
+ meta = {
+ homepage = "https://github.com/sainnhe/tmux-fzf";
+ description = "Use fzf to manage your tmux work environment! ";
+ longDescription =
+ ''
+ Features:
+ * Manage sessions (attach, detach*, rename, kill*).
+ * Manage windows (switch, link, move, swap, rename, kill*).
+ * Manage panes (switch, break, join*, swap, layout, kill*, resize).
+ * Multiple selection (support for actions marked by *).
+ * Search commands and append to command prompt.
+ * Search key bindings and execute.
+ * User menu.
+ * Popup window support.
+ '';
+ license = stdenv.lib.licenses.mit;
+ platforms = stdenv.lib.platforms.unix;
+ maintainers = with stdenv.lib.maintainers; [ kyleondy ];
+ };
+ };
+
urlview = mkDerivation {
pluginName = "urlview";
version = "unstable-2016-01-06";