aboutsummaryrefslogtreecommitdiff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorAlexander V. Nikolaev <avn@avnik.info>2020-11-23 18:01:00 +0200
committerAlexander V. Nikolaev <avn@avnik.info>2020-11-24 00:54:08 +0200
commit22da5d92aff8f7c962b5d9da9c422b9071104cb3 (patch)
treea4bfe301784c5dfb6effb9357bc12a4278111a0d /pkgs/misc
parent152147a8f6548c83d9944a0e6aecd350becfeb09 (diff)
wine{Unstable,Staging}: 5.21 -> 5.22
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/cert-path.patch41
-rw-r--r--pkgs/misc/emulators/wine/sources.nix6
2 files changed, 23 insertions, 24 deletions
diff --git a/pkgs/misc/emulators/wine/cert-path.patch b/pkgs/misc/emulators/wine/cert-path.patch
index da01a4778102..18a90e1a9af8 100644
--- a/pkgs/misc/emulators/wine/cert-path.patch
+++ b/pkgs/misc/emulators/wine/cert-path.patch
@@ -1,24 +1,23 @@
-diff --git a/dlls/crypt32/rootstore.c b/dlls/crypt32/rootstore.c
-index f795181..fb4926a 100644
---- a/dlls/crypt32/rootstore.c
-+++ b/dlls/crypt32/rootstore.c
-@@ -18,6 +18,7 @@
- #include "config.h"
+diff --git a/dlls/crypt32/unixlib.c b/dlls/crypt32/unixlib.c
+index 035f2d936bb..959716d727a 100644
+--- a/dlls/crypt32/unixlib.c
++++ b/dlls/crypt32/unixlib.c
+@@ -24,6 +24,7 @@
+ #include "wine/port.h"
+
#include <stdarg.h>
- #include <stdio.h>
-+#include <stdlib.h> /* getenv */
- #include <sys/types.h>
- #ifdef HAVE_SYS_STAT_H
- #include <sys/stat.h>
-@@ -916,6 +917,11 @@ static void read_trusted_roots_from_known_locations(HCERTSTORE store)
++#include <stdlib.h>
+ #include <dirent.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+@@ -605,6 +606,10 @@ static void load_root_certs(void)
- for (i = 0; !ret && i < ARRAY_SIZE(CRYPT_knownLocations); i++)
- ret = import_certs_from_path(CRYPT_knownLocations[i], from, TRUE);
-+
-+ char *nix_cert_file = getenv("NIX_SSL_CERT_FILE");
-+ if (nix_cert_file != NULL)
-+ ret = import_certs_from_path(nix_cert_file, from, TRUE);
+ for (i = 0; i < ARRAY_SIZE(CRYPT_knownLocations) && list_empty(&root_cert_list); i++)
+ import_certs_from_path( CRYPT_knownLocations[i], TRUE );
+
- check_and_store_certs(from, store);
- }
- CertCloseStore(from, 0);
++ char *nix_cert_file = getenv("NIX_SSL_CERT_FILE");
++ if (nix_cert_file != NULL)
++ import_certs_from_path(nix_cert_file, TRUE);
+ }
+
+ static BOOL WINAPI enum_root_certs( void *buffer, SIZE_T size, SIZE_T *needed )
diff --git a/pkgs/misc/emulators/wine/sources.nix b/pkgs/misc/emulators/wine/sources.nix
index b722e697ee1e..081594e62147 100644
--- a/pkgs/misc/emulators/wine/sources.nix
+++ b/pkgs/misc/emulators/wine/sources.nix
@@ -39,16 +39,16 @@ in rec {
unstable = fetchurl rec {
# NOTE: Don't forget to change the SHA256 for staging as well.
- version = "5.21";
+ version = "5.22";
url = "https://dl.winehq.org/wine/source/5.x/wine-${version}.tar.xz";
- sha256 = "sha256-WhpcJUnRG84NZkAiDtb9MQQq/LyzZvR14My0eB0tKEA=";
+ sha256 = "sha256-Cb0GyHyMl05q00UHzsh11yF+tW/Anfg41UU+DrvOTSE=";
inherit (stable) mono gecko32 gecko64;
};
staging = fetchFromGitHub rec {
# https://github.com/wine-staging/wine-staging/releases
inherit (unstable) version;
- sha256 = "sha256-8IIjdGyRZf2v0dVvinqA2gvjR5eCXxN3+tWj1eCjjWA=";
+ sha256 = "sha256-witIBZB8LRNSGTbBB7Rkm9QGvkH4EMuLc6gUpcqVVGo=";
owner = "wine-staging";
repo = "wine-staging";
rev = "v${version}";