aboutsummaryrefslogtreecommitdiff
path: root/pkgs/games
diff options
context:
space:
mode:
authorFabian Möller <fabianm88@gmail.com>2020-11-27 13:45:59 +0100
committerMilan Pässler <milan@petabyte.dev>2020-11-29 04:17:12 +0100
commit74088bad64c6bbcee93e50130f8207d4846c9629 (patch)
tree9ed0d71b3bb35ac08cc6cdde5d560cb830180fe0 /pkgs/games
parent81e2df3ce1e2db7e34cc54668848fbe095f7e80c (diff)
xonotic: use copyDesktopItems hook
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/xonotic/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/games/xonotic/default.nix b/pkgs/games/xonotic/default.nix
index ab6ac022b6c2..60ebdcf8eebf 100644
--- a/pkgs/games/xonotic/default.nix
+++ b/pkgs/games/xonotic/default.nix
@@ -1,5 +1,5 @@
{ lib, stdenv, fetchurl, fetchzip, makeWrapper, runCommandNoCC, makeDesktopItem
-, xonotic-data
+, xonotic-data, copyDesktopItems
, # required for both
unzip, libjpeg, zlib, libvorbis, curl
, # glx
@@ -131,7 +131,8 @@ in rec {
xonotic = runCommandNoCC "xonotic${variant}-${version}" {
inherit xonotic-unwrapped;
- buildInputs = [ makeWrapper ];
+ nativeBuildInputs = [ makeWrapper copyDesktopItems ];
+ desktopItems = [ desktopItem ];
passthru = {
inherit version;
meta = meta // {
@@ -151,7 +152,7 @@ in rec {
'' + lib.optionalString (withSDL || withGLX) ''
mkdir -p $out/share
ln -s ${xonotic-unwrapped}/share/icons $out/share/icons
- ${desktopItem.buildCommand}
+ copyDesktopItems
'' + ''
for binary in $out/bin/xonotic-*; do
wrapProgram $binary --add-flags "-basedir ${xonotic-data}"