aboutsummaryrefslogtreecommitdiff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorAndré Silva <andrerfosilva@gmail.com>2020-11-22 19:37:32 +0000
committerAndré Silva <andrerfosilva@gmail.com>2020-11-23 12:39:12 +0000
commit4d4d16a92666cd7ae62ab8d1ac869b2cfec785ae (patch)
treeb3881efda1dc4a89a049342fb3cf20ec00b47e22 /pkgs/desktops
parenta322b32e9d74fb476944ff6cfb55833dc69cfaaa (diff)
thunar: fix wrapper build
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/xfce/core/thunar/wrapper.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/pkgs/desktops/xfce/core/thunar/wrapper.nix b/pkgs/desktops/xfce/core/thunar/wrapper.nix
index cc44e6624571..b0b4268db6ec 100644
--- a/pkgs/desktops/xfce/core/thunar/wrapper.nix
+++ b/pkgs/desktops/xfce/core/thunar/wrapper.nix
@@ -14,7 +14,14 @@ symlinkJoin {
wrapProgram "$out/bin/thunar-settings" \
--set "THUNARX_MODULE_DIR" "$out/lib/thunarx-3"
- for file in "lib/systemd/user/thunar.service" "share/dbus-1/services/org.xfce.FileManager.service" \
+ # NOTE: we need to remove the folder symlink itself and create
+ # a new folder before trying to substitute any file below.
+ rm -f "$out/lib/systemd/user"
+ mkdir -p "$out/lib/systemd/user"
+
+ # point to wrapped binary in all service files
+ for file in "lib/systemd/user/thunar.service" \
+ "share/dbus-1/services/org.xfce.FileManager.service" \
"share/dbus-1/services/org.xfce.Thunar.FileManager1.service" \
"share/dbus-1/services/org.xfce.Thunar.service"
do
@@ -24,7 +31,7 @@ symlinkJoin {
done
'';
- meta = with lib; {
+ meta = with lib; {
inherit (thunar.meta) homepage license platforms maintainers;
description = thunar.meta.description + optionalString