aboutsummaryrefslogtreecommitdiff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2020-12-03 18:14:40 +0000
committerGitHub <noreply@github.com>2020-12-03 18:14:40 +0000
commit1aeec1f039ecfb360c0ee931af15458452dd3871 (patch)
tree8846aaf219de5c884b8e80610609a3752c746d42 /pkgs/applications
parent5b73e3087ae63d404f94a76781b281e73a33922b (diff)
parent555641c50462d5ab87afe9ceab7df9d8c7755a37 (diff)
Merge master into staging-next
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs/generic.nix2
-rw-r--r--pkgs/applications/misc/archivy/default.nix4
-rw-r--r--pkgs/applications/misc/joplin-desktop/default.nix6
-rw-r--r--pkgs/applications/networking/cluster/starboard/default.nix6
-rw-r--r--pkgs/applications/networking/cluster/terraform-providers/providers.json8
-rw-r--r--pkgs/applications/networking/cluster/terraform/default.nix27
-rw-r--r--pkgs/applications/networking/dyndns/dyndnsc/default.nix59
-rw-r--r--pkgs/applications/science/robotics/mavproxy/default.nix4
8 files changed, 93 insertions, 23 deletions
diff --git a/pkgs/applications/editors/emacs/generic.nix b/pkgs/applications/editors/emacs/generic.nix
index a0bd1193d2cd..0e09b0c20ee0 100644
--- a/pkgs/applications/editors/emacs/generic.nix
+++ b/pkgs/applications/editors/emacs/generic.nix
@@ -154,6 +154,8 @@ in stdenv.mkDerivation {
'' + lib.optionalString withNS ''
mkdir -p $out/Applications
mv nextstep/Emacs.app $out/Applications
+ '' + lib.optionalString (nativeComp && withNS) ''
+ ln -snf $out/lib/emacs/*/native-lisp $out/Applications/Emacs.app/Contents/native-lisp
'';
postFixup = lib.concatStringsSep "\n" [
diff --git a/pkgs/applications/misc/archivy/default.nix b/pkgs/applications/misc/archivy/default.nix
index d2fa48cd2348..09779f8876f8 100644
--- a/pkgs/applications/misc/archivy/default.nix
+++ b/pkgs/applications/misc/archivy/default.nix
@@ -5,11 +5,11 @@ watchdog, wtforms }:
python3.pkgs.buildPythonApplication rec {
pname = "archivy";
- version = "0.8.5";
+ version = "0.9.2";
src = fetchPypi {
inherit pname version;
- sha256 = "144ckgxjaw29yp5flyxd1rnkm7hlim4zgy6xng7x0a9j54h527iq";
+ sha256 = "5cb760da57dc9dcdd62c0af824993d1715ec7035915629b4046d8bf50442756c";
};
# Relax some dependencies
diff --git a/pkgs/applications/misc/joplin-desktop/default.nix b/pkgs/applications/misc/joplin-desktop/default.nix
index fccf15c0241b..bcd4f686f818 100644
--- a/pkgs/applications/misc/joplin-desktop/default.nix
+++ b/pkgs/applications/misc/joplin-desktop/default.nix
@@ -2,7 +2,7 @@
let
pname = "joplin-desktop";
- version = "1.4.15";
+ version = "1.4.19";
name = "${pname}-${version}";
inherit (stdenv.hostPlatform) system;
@@ -16,8 +16,8 @@ let
src = fetchurl {
url = "https://github.com/laurent22/joplin/releases/download/v${version}/Joplin-${version}.${suffix}";
sha256 = {
- x86_64-linux = "12wh7f1a9sn250lqnb8c9b5gqr8r76kxrhl0kgsm2lg93jgpvvbb";
- x86_64-darwin = "1jzfqwyz3vkmmkdzx3iw36fbjq7fns46v8crmg5n09w9kvf22qil";
+ x86_64-linux = "1xyj30pnlczchbh4awb955sxh51v89d170f4yk0v1jkj7dg2wjgj";
+ x86_64-darwin = "166yp2rr87p0lh64ngs498a50ahcann8z5s0g2p0azs6wi54a6kw";
}.${system} or throwSystem;
};
diff --git a/pkgs/applications/networking/cluster/starboard/default.nix b/pkgs/applications/networking/cluster/starboard/default.nix
index bc42bf13666a..bb4327064527 100644
--- a/pkgs/applications/networking/cluster/starboard/default.nix
+++ b/pkgs/applications/networking/cluster/starboard/default.nix
@@ -2,16 +2,16 @@
buildGoModule rec {
pname = "starboard";
- version = "0.6.0";
+ version = "0.7.0";
src = fetchFromGitHub {
owner = "aquasecurity";
repo = pname;
rev = "v${version}";
- sha256 = "00d3cnd3n6laa6rphw5w9xk8slpp4a603vzhixzg01sghq26gy22";
+ sha256 = "1xj0fa52973h7cg3scxn85lav98q6fz82dwd5cls3p39ghnhzn5l";
};
- vendorSha256 = "0y816r75rp1a4rp7j0a8wzrfi2mdf4ji1vz2vaj5s7x9ik6rc13r";
+ vendorSha256 = "07cz4p8k927ash5ncw1r56bcn592imgywbyzkvhnn50pap91m0q0";
subPackages = [ "cmd/starboard" ];
diff --git a/pkgs/applications/networking/cluster/terraform-providers/providers.json b/pkgs/applications/networking/cluster/terraform-providers/providers.json
index 83865214192a..bb2a7ab582b9 100644
--- a/pkgs/applications/networking/cluster/terraform-providers/providers.json
+++ b/pkgs/applications/networking/cluster/terraform-providers/providers.json
@@ -720,11 +720,11 @@
"version": "0.8.0"
},
"packet": {
- "owner": "terraform-providers",
+ "owner": "packethost",
"repo": "terraform-provider-packet",
- "rev": "v2.9.0",
- "sha256": "0d9r272gidkwn4zr130ml047512qq5d5d599s63blzy6m38vilha",
- "version": "2.9.0"
+ "rev": "v3.2.0",
+ "sha256": "sha256-YIv4OPRbR00YTVwz0iJ/y6qTbj50nsi5ylrWEx1kZck=",
+ "version": "3.2.0"
},
"pagerduty": {
"owner": "terraform-providers",
diff --git a/pkgs/applications/networking/cluster/terraform/default.nix b/pkgs/applications/networking/cluster/terraform/default.nix
index b478071ead16..d8c17a89e69b 100644
--- a/pkgs/applications/networking/cluster/terraform/default.nix
+++ b/pkgs/applications/networking/cluster/terraform/default.nix
@@ -1,15 +1,13 @@
-{ stdenv, lib, buildEnv, buildGoPackage, fetchFromGitHub, makeWrapper, coreutils
+{ stdenv, lib, buildGoModule, fetchFromGitHub, makeWrapper, coreutils
, runCommand, runtimeShell, writeText, terraform-providers, fetchpatch }:
let
- goPackagePath = "github.com/hashicorp/terraform";
-
- generic = { version, sha256, ... }@attrs:
- let attrs' = builtins.removeAttrs attrs [ "version" "sha256" ];
- in buildGoPackage ({
+ generic = { version, sha256, vendorSha256 ? null, ... }@attrs:
+ let attrs' = builtins.removeAttrs attrs [ "version" "sha256" "vendorSha256" ];
+ in buildGoModule ({
name = "terraform-${version}";
- inherit goPackagePath;
+ inherit vendorSha256;
src = fetchFromGitHub {
owner = "hashicorp";
@@ -18,7 +16,7 @@ let
inherit sha256;
};
- postPatch = ''
+ postConfigure = ''
# speakeasy hardcodes /bin/stty https://github.com/bgentry/speakeasy/issues/22
substituteInPlace vendor/github.com/bgentry/speakeasy/speakeasy_unix.go \
--replace "/bin/stty" "${coreutils}/bin/stty"
@@ -34,9 +32,12 @@ let
'';
preCheck = ''
- export HOME=$TMP
+ export HOME=$TMPDIR
+ export TF_SKIP_REMOTE_TESTS=1
'';
+ subPackages = [ "." ];
+
meta = with stdenv.lib; {
description =
"Tool for building, changing, and versioning infrastructure";
@@ -163,6 +164,14 @@ in rec {
passthru = { inherit plugins; };
});
+ terraform_0_14 = pluggable (generic {
+ version = "0.14.0";
+ sha256 = "0pbglnvb6cx8zrz791lfa67dmjqfsyysbxm2083b1lhlmbybi9ax";
+ vendorSha256 = "1gxhdj98np482jm76aj6zbbmkn7vfk8b878hzz59iywgbdr1r4m1";
+ patches = [ ./provider-path.patch ];
+ passthru = { inherit plugins; };
+ });
+
# Tests that the plugins are being used. Terraform looks at the specific
# file pattern and if the plugin is not found it will try to download it
# from the Internet. With sandboxing enable this test will fail if that is
diff --git a/pkgs/applications/networking/dyndns/dyndnsc/default.nix b/pkgs/applications/networking/dyndns/dyndnsc/default.nix
new file mode 100644
index 000000000000..65d463057416
--- /dev/null
+++ b/pkgs/applications/networking/dyndns/dyndnsc/default.nix
@@ -0,0 +1,59 @@
+{ stdenv, lib, python3Packages }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "dyndnsc";
+ version = "0.5.1";
+
+ src = python3Packages.fetchPypi {
+ inherit pname version;
+ hash = "sha256-Sy6U0XhIQ9mPmznmWKqoyqE34vaE84fwlivouaF7Dd0=";
+ };
+
+ postPatch = ''
+ substituteInPlace setup.py --replace "bottle==" "bottle>="
+ '';
+
+ nativeBuildInputs = with python3Packages; [ pytestrunner ];
+ propagatedBuildInputs = with python3Packages; [
+ daemonocle
+ dnspython
+ netifaces
+ requests
+ setuptools
+ ];
+ checkInputs = with python3Packages; [ bottle pytestCheckHook ];
+
+ disabledTests = [
+ # dnswanip connects to an external server to discover the
+ # machine's IP address.
+ "dnswanip"
+ ] ++ lib.optionals stdenv.isDarwin [
+ # The tests that spawn a server using Bottle cannot be run on
+ # macOS or Windows as the default multiprocessing start method
+ # on those platforms is 'spawn', which requires the code to be
+ # run to be picklable, which this code isn't.
+ # Additionaly, other start methods are unsafe and prone to failure
+ # on macOS; see https://bugs.python.org/issue33725.
+ "BottleServer"
+ ];
+ # Allow tests that bind or connect to localhost on macOS.
+ __darwinAllowLocalNetworking = true;
+
+ meta = with lib; {
+ description = "Dynamic DNS update client with support for multiple protocols";
+ longDescription = ''
+ Dyndnsc is a command line client for sending updates to Dynamic
+ DNS (DDNS, DynDNS) services. It supports multiple protocols and
+ services, and it has native support for IPv6. The configuration
+ file allows using foreign, but compatible services. Dyndnsc
+ ships many different IP detection mechanisms, support for
+ configuring multiple services in one place and it has a daemon
+ mode for running unattended. It has a plugin system to provide
+ external notification services.
+ '';
+ homepage = "https://github.com/infothrill/python-dyndnsc";
+ license = licenses.mit;
+ maintainers = with maintainers; [ AluisioASG ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/applications/science/robotics/mavproxy/default.nix b/pkgs/applications/science/robotics/mavproxy/default.nix
index 6fdb7b8fcbe2..a71ddc874c9d 100644
--- a/pkgs/applications/science/robotics/mavproxy/default.nix
+++ b/pkgs/applications/science/robotics/mavproxy/default.nix
@@ -3,11 +3,11 @@
buildPythonApplication rec {
pname = "MAVProxy";
- version = "1.8.27";
+ version = "1.8.29";
src = fetchPypi {
inherit pname version;
- sha256 = "f3c704e2d67b36e4932896abe00c89e7f3fb7458fc52849b5d7d6d83bd623adf";
+ sha256 = "8f5900dc0a404ab9cf5a00155f83e9aaeab18161ce21a352dfdcf2d7abf5d78e";
};
propagatedBuildInputs = [