aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/systemd-networkd.nix
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2020-08-29 22:45:27 +0200
committerMaximilian Bosch <maximilian@mbosch.me>2020-08-29 22:51:30 +0200
commitd416facd395254666e0333f609520d86e64059a7 (patch)
tree7d9860e2144804b26f2e35f3d4c427d51d8add90 /nixos/tests/systemd-networkd.nix
parentb12ca077c011122a0303a856944ea746f719df1d (diff)
nixos/tests/systemd-networkd: fix eval
In `systemd-243` the option `FwMark` in the `[WireGuard]` section of a `.netdev`-unit has been renamed to `FirewallMark`[1]. Due to the removal of deprecated options in our `networkd` module[2] the evaluation of this test doesn't work. Renaming the option to its new name fixes the issue. [1] https://github.com/systemd/systemd/commit/1c30b174edc001537350036245ea632cb4e91cbb [2] e9d13d37515cde47ec24410ca19866e68e5a7bd5
Diffstat (limited to 'nixos/tests/systemd-networkd.nix')
-rw-r--r--nixos/tests/systemd-networkd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/systemd-networkd.nix b/nixos/tests/systemd-networkd.nix
index 319e5e94eceb..162970e67537 100644
--- a/nixos/tests/systemd-networkd.nix
+++ b/nixos/tests/systemd-networkd.nix
@@ -18,7 +18,7 @@ let generateNodeConf = { lib, pkgs, config, privk, pubk, peerId, nodeId, ...}: {
wireguardConfig = {
PrivateKeyFile = "/run/wg_priv";
ListenPort = 51820;
- FwMark = 42;
+ FirewallMark = 42;
};
wireguardPeers = [ {wireguardPeerConfig={
Endpoint = "192.168.1.${peerId}:51820";