aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/syncthing-relay.nix
diff options
context:
space:
mode:
authorPierre Bourdon <delroth@gmail.com>2018-11-17 15:02:00 +0100
committerPierre Bourdon <delroth@gmail.com>2018-11-19 01:09:54 +0100
commit08f24cadaa65c367dd6599d0d7b1260d915cf527 (patch)
treee64827c68fac3147d82f9dc8c0c65953f9a03070 /nixos/tests/syncthing-relay.nix
parent47b3086bdf59a4df366550185863a149392d55fe (diff)
syncthing-relay module: init
Diffstat (limited to 'nixos/tests/syncthing-relay.nix')
-rw-r--r--nixos/tests/syncthing-relay.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nixos/tests/syncthing-relay.nix b/nixos/tests/syncthing-relay.nix
new file mode 100644
index 000000000000..f1ceb4993337
--- /dev/null
+++ b/nixos/tests/syncthing-relay.nix
@@ -0,0 +1,22 @@
+import ./make-test.nix ({ lib, pkgs, ... }: {
+ name = "syncthing-relay";
+ meta.maintainers = with pkgs.stdenv.lib.maintainers; [ delroth ];
+
+ machine = {
+ environment.systemPackages = [ pkgs.jq ];
+ services.syncthing.relay = {
+ enable = true;
+ providedBy = "nixos-test";
+ pools = []; # Don't connect to any pool while testing.
+ port = 12345;
+ statusPort = 12346;
+ };
+ };
+
+ testScript = ''
+ $machine->waitForUnit("syncthing-relay.service");
+ $machine->waitForOpenPort(12345);
+ $machine->waitForOpenPort(12346);
+ $machine->succeed("curl http://localhost:12346/status | jq -r '.options.\"provided-by\"'") =~ /nixos-test/ or die;
+ '';
+})