aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/solr.nix
diff options
context:
space:
mode:
authorJacek Galowicz <jacek.galowicz@cyberus-technology.de>2020-02-13 22:40:47 +0100
committerJacek Galowicz <jacek.galowicz@cyberus-technology.de>2020-02-13 22:40:47 +0100
commit36b808de5fb0fe43d2906e89b3b0d605cba547c0 (patch)
tree6421206437b7e293a2d9654c25cdafa6d9ba5702 /nixos/tests/solr.nix
parent0a33a4ab113ad7f89a694f93c91217af221cabe3 (diff)
nixosTests.solr: Port to python
Diffstat (limited to 'nixos/tests/solr.nix')
-rw-r--r--nixos/tests/solr.nix50
1 files changed, 29 insertions, 21 deletions
diff --git a/nixos/tests/solr.nix b/nixos/tests/solr.nix
index 23e1a960fb37..dc5770e16bc7 100644
--- a/nixos/tests/solr.nix
+++ b/nixos/tests/solr.nix
@@ -1,4 +1,4 @@
-import ./make-test.nix ({ pkgs, ... }:
+import ./make-test-python.nix ({ pkgs, ... }:
{
name = "solr";
@@ -21,28 +21,36 @@ import ./make-test.nix ({ pkgs, ... }:
};
testScript = ''
- startAll;
+ start_all()
- $machine->waitForUnit('solr.service');
- $machine->waitForOpenPort('8983');
- $machine->succeed('curl --fail http://localhost:8983/solr/');
+ machine.wait_for_unit("solr.service")
+ machine.wait_for_open_port(8983)
+ machine.succeed("curl --fail http://localhost:8983/solr/")
# adapted from pkgs.solr/examples/films/README.txt
- $machine->succeed('sudo -u solr solr create -c films');
- $machine->succeed(q(curl http://localhost:8983/solr/films/schema -X POST -H 'Content-type:application/json' --data-binary '{
- "add-field" : {
- "name":"name",
- "type":"text_general",
- "multiValued":false,
- "stored":true
- },
- "add-field" : {
- "name":"initial_release_date",
- "type":"pdate",
- "stored":true
- }
- }')) =~ /"status":0/ or die;
- $machine->succeed('sudo -u solr post -c films ${pkgs.solr}/example/films/films.json');
- $machine->succeed('curl http://localhost:8983/solr/films/query?q=name:batman') =~ /"name":"Batman Begins"/ or die;
+ machine.succeed("sudo -u solr solr create -c films")
+ assert '"status":0' in machine.succeed(
+ """
+ curl http://localhost:8983/solr/films/schema -X POST -H 'Content-type:application/json' --data-binary '{
+ "add-field" : {
+ "name":"name",
+ "type":"text_general",
+ "multiValued":false,
+ "stored":true
+ },
+ "add-field" : {
+ "name":"initial_release_date",
+ "type":"pdate",
+ "stored":true
+ }
+ }'
+ """
+ )
+ machine.succeed(
+ "sudo -u solr post -c films ${pkgs.solr}/example/films/films.json"
+ )
+ assert '"name":"Batman Begins"' in machine.succeed(
+ "curl http://localhost:8983/solr/films/query?q=name:batman"
+ )
'';
})