aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/slurm.nix
diff options
context:
space:
mode:
authorMarkus Kowalewski <markus.kowalewski@gmail.com>2018-12-09 13:36:53 +0100
committerMarkus Kowalewski <markus.kowalewski@gmail.com>2018-12-09 13:36:53 +0100
commit8eee1ec2a9f0925bcf9589b330faacd0255ae700 (patch)
treedfee209664de94a1338821d95cc06a63dad42df6 /nixos/tests/slurm.nix
parent0ed4fc606ae0ee92113fe72f17cf3ee5381bd8f8 (diff)
tests/slurm: wait for open DBD port
This makes tests more reliable. It seems that waitForUnit(slurmdbd.service) is not sufficient on some systems.
Diffstat (limited to 'nixos/tests/slurm.nix')
-rw-r--r--nixos/tests/slurm.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/tests/slurm.nix b/nixos/tests/slurm.nix
index 30e408c7db1e..b4458d8d0954 100644
--- a/nixos/tests/slurm.nix
+++ b/nixos/tests/slurm.nix
@@ -101,6 +101,7 @@ in {
subtest "can_start_slurmdbd", sub {
$dbd->succeed("systemctl restart slurmdbd");
$dbd->waitForUnit("slurmdbd.service");
+ $dbd->waitForOpenPort(6819);
};
# there needs to be an entry for the current