aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/sddm.nix
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-11-12 12:46:02 -0500
committerworldofpeace <worldofpeace@protonmail.ch>2019-11-12 12:46:30 -0500
commitcf74d290aefbfacfee71f6e97dd4ef112285b48a (patch)
treeaa411f286398a417a73ad7d1ea6ce21d5d60d5ea /nixos/tests/sddm.nix
parent57bcbb4c999994de2aaaec03e0f2a2def81dfe41 (diff)
nixosTests.sddm: make regex case insensitive
I read the q/select your user/i as q/select your user/ not noticing it needed to be case insensitive.
Diffstat (limited to 'nixos/tests/sddm.nix')
-rw-r--r--nixos/tests/sddm.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/sddm.nix b/nixos/tests/sddm.nix
index 11d60598445e..4bdcd701dcf1 100644
--- a/nixos/tests/sddm.nix
+++ b/nixos/tests/sddm.nix
@@ -27,7 +27,7 @@ let
user = nodes.machine.config.users.users.alice;
in ''
start_all()
- machine.wait_for_text("select your user")
+ machine.wait_for_text("(?i)select your user")
machine.screenshot("sddm")
machine.send_chars("${user.password}\n")
machine.wait_for_file("${user.home}/.Xauthority")