aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/sddm.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2017-06-22 06:25:31 +0200
committeraszlig <aszlig@redmoonstudios.org>2017-06-22 06:26:08 +0200
commitbcaf2f6dbe5369f4835cfff31639f07b70bcb670 (patch)
treebe6f726b4223e780c056abf1b85406fe1297b33d /nixos/tests/sddm.nix
parent4007ee974c68a65444d939312ffe308297bdd3f6 (diff)
nixos/tests/sddm: Fix detecting login screen
Tesseract seems to have a hard time detecting the "ALICE FOOBAR" text, so let's match on "Select your user and enter password" instead. Ran the test on x86_64-linux and it now succeeds. Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/tests/sddm.nix')
-rw-r--r--nixos/tests/sddm.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/sddm.nix b/nixos/tests/sddm.nix
index 82be9bc1d727..1ce2b8157842 100644
--- a/nixos/tests/sddm.nix
+++ b/nixos/tests/sddm.nix
@@ -24,7 +24,7 @@ let
user = nodes.machine.config.users.extraUsers.alice;
in ''
startAll;
- $machine->waitForText(qr/ALICE/);
+ $machine->waitForText(qr/select your user/i);
$machine->screenshot("sddm");
$machine->sendChars("${user.password}\n");
$machine->waitForFile("/home/alice/.Xauthority");