aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/run-in-machine.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-16 11:36:09 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-16 11:37:38 +0200
commit6dafee8d6704957e123de1b51d3e406848f4aac8 (patch)
treea91bacfa73d9fd189d82fa9030b12a8af7a8dec0 /nixos/tests/run-in-machine.nix
parente0db0aaa4d4a9169b5e1f4d1d6e23d6dffc5d0ab (diff)
Fix runInMachine
It requires a writable /nix/store to store the build result. Also, wait until we've reached multi-user.target before doing the build, and do a sync at the end to ensure all data to $out is properly written. http://hydra.nixos.org/build/6496716
Diffstat (limited to 'nixos/tests/run-in-machine.nix')
-rw-r--r--nixos/tests/run-in-machine.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/nixos/tests/run-in-machine.nix b/nixos/tests/run-in-machine.nix
index 75bd161ec9ef..8efe26c17082 100644
--- a/nixos/tests/run-in-machine.nix
+++ b/nixos/tests/run-in-machine.nix
@@ -1,10 +1,8 @@
-{ nixpkgs ? <nixpkgs>
-, system ? builtins.currentSystem
-}:
+{ system ? builtins.currentSystem }:
with import ../lib/testing.nix { inherit system; };
runInMachine {
- drv = (import nixpkgs { inherit system; }).aterm;
+ drv = pkgs.patchelf;
machine = { config, pkgs, ... }: { services.sshd.enable = true; };
}