aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/plasma5.nix
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@mailbox.org>2017-03-24 08:02:24 -0500
committerThomas Tuegel <ttuegel@mailbox.org>2017-03-24 09:45:57 -0500
commit27ba56f1e01e5015897be087fe25d5bbcfe13d70 (patch)
tree44d92ab40edfa092752fb4eac4b9e398733e69de /nixos/tests/plasma5.nix
parentf815a7697e09b0b72fe2d06fd29ae1aeee6cdb5a (diff)
nixos/plasma5: also test SDDM theme
Diffstat (limited to 'nixos/tests/plasma5.nix')
-rw-r--r--nixos/tests/plasma5.nix26
1 files changed, 14 insertions, 12 deletions
diff --git a/nixos/tests/plasma5.nix b/nixos/tests/plasma5.nix
index ca787e9c7b9b..f561fc8c3c4c 100644
--- a/nixos/tests/plasma5.nix
+++ b/nixos/tests/plasma5.nix
@@ -8,25 +8,27 @@ import ./make-test.nix ({ pkgs, ...} :
machine = { lib, ... }: {
imports = [ ./common/user-account.nix ];
- virtualisation.memorySize = 1024;
services.xserver.enable = true;
- services.xserver.displayManager.sddm = {
- enable = true;
- autoLogin = {
- enable = true;
- user = "alice";
- };
- };
+ services.xserver.displayManager.sddm.enable = true;
services.xserver.desktopManager.plasma5.enable = true;
services.xserver.desktopManager.default = "plasma5";
- virtualisation.writableStore = false; # FIXME
+ virtualisation.memorySize = 1024;
};
- testScript = { nodes, ... }:
- let xdo = "${pkgs.xdotool}/bin/xdotool"; in
- ''
+ enableOCR = true;
+
+ testScript = { nodes, ... }: let
+ user = nodes.machine.config.users.extraUsers.alice;
+ xdo = "${pkgs.xdotool}/bin/xdotool";
+ in ''
startAll;
+ # Wait for display manager to start
+ $machine->waitForText(qr/${user.description}/);
+ $machine->screenshot("sddm");
+
+ # Log in
+ $machine->sendChars("${user.password}\n");
$machine->waitForFile("/home/alice/.Xauthority");
$machine->succeed("xauth merge ~alice/.Xauthority");