aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/openssh.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-10 13:28:20 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-10 13:28:20 +0200
commit5c1f8cbc70cd5e6867ef6a2a06d27a40daa07010 (patch)
treea6c0f605be6de3f372ae69905b331f9f75452da7 /nixos/tests/openssh.nix
parent6070bc016bd2fd945b04347e25cfd3738622d2ac (diff)
Move all of NixOS to nixos/ in preparation of the repository merge
Diffstat (limited to 'nixos/tests/openssh.nix')
-rw-r--r--nixos/tests/openssh.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nixos/tests/openssh.nix b/nixos/tests/openssh.nix
new file mode 100644
index 000000000000..16757cf9098e
--- /dev/null
+++ b/nixos/tests/openssh.nix
@@ -0,0 +1,35 @@
+{ pkgs, ... }:
+
+{
+ nodes = {
+
+ server =
+ { config, pkgs, ... }:
+
+ {
+ services.openssh.enable = true;
+ };
+
+ client =
+ { config, pkgs, ... }: { };
+
+ };
+
+ testScript = ''
+ startAll;
+
+ my $key=`${pkgs.openssh}/bin/ssh-keygen -t dsa -f key -N ""`;
+
+ $server->waitForUnit("sshd");
+
+ $server->succeed("mkdir -m 700 /root/.ssh");
+ $server->copyFileFromHost("key.pub", "/root/.ssh/authorized_keys");
+
+ $client->succeed("mkdir -m 700 /root/.ssh");
+ $client->copyFileFromHost("key", "/root/.ssh/id_dsa");
+ $client->succeed("chmod 600 /root/.ssh/id_dsa");
+
+ $client->waitForUnit("network.target");
+ $client->succeed("ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no server 'echo hello world' >&2");
+ '';
+}