aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/nginx.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@nix.build>2019-04-18 09:35:26 +0200
committeraszlig <aszlig@nix.build>2019-04-18 09:41:13 +0200
commitd533285224de23354f445f728049e7758d686f20 (patch)
tree87097558869bb7e046d342b76f8e35c3417ae8ab /nixos/tests/nginx.nix
parentaf5a3ce4740e78b667994ed444a72bec610b3ec8 (diff)
nixos/tests/nginx: Add subtest for Nix ETag patch
This is to make sure that we get different ETag values whenever we switch to a different store path but with the same file contents. I've checked this against the old behaviour without the patch and it fails as expected. Signed-off-by: aszlig <aszlig@nix.build>
Diffstat (limited to 'nixos/tests/nginx.nix')
-rw-r--r--nixos/tests/nginx.nix70
1 files changed, 56 insertions, 14 deletions
diff --git a/nixos/tests/nginx.nix b/nixos/tests/nginx.nix
index a4d14986a146..d66d99821c11 100644
--- a/nixos/tests/nginx.nix
+++ b/nixos/tests/nginx.nix
@@ -1,18 +1,19 @@
# verifies:
# 1. nginx generates config file with shared http context definitions above
# generated virtual hosts config.
+# 2. whether the ETag header is properly generated whenever we're serving
+# files in Nix store paths
-import ./make-test.nix ({ pkgs, ...} : {
+import ./make-test.nix ({ pkgs, ... }: {
name = "nginx";
meta = with pkgs.stdenv.lib.maintainers; {
maintainers = [ mbbx6spp ];
};
- nodes = {
- webserver =
- { ... }:
- { services.nginx.enable = true;
- services.nginx.commonHttpConfig = ''
+ nodes = let
+ commonConfig = { pkgs, ... }: {
+ services.nginx.enable = true;
+ services.nginx.commonHttpConfig = ''
log_format ceeformat '@cee: {"status":"$status",'
'"request_time":$request_time,'
'"upstream_response_time":$upstream_response_time,'
@@ -24,20 +25,61 @@ import ./make-test.nix ({ pkgs, ...} : {
'"request":"$request",'
'"http_referer":"$http_referer",'
'"upstream_addr":"$upstream_addr"}';
+ '';
+ services.nginx.virtualHosts."0.my.test" = {
+ extraConfig = ''
+ access_log syslog:server=unix:/dev/log,facility=user,tag=mytag,severity=info ceeformat;
+ location /favicon.ico { allow all; access_log off; log_not_found off; }
'';
- services.nginx.virtualHosts."0.my.test" = {
- extraConfig = ''
- access_log syslog:server=unix:/dev/log,facility=user,tag=mytag,severity=info ceeformat;
- location /favicon.ico { allow all; access_log off; log_not_found off; }
- '';
- };
};
+ services.nginx.virtualHosts.localhost = {
+ root = pkgs.runCommand "testdir" {} ''
+ mkdir "$out"
+ echo hello world > "$out/index.html"
+ '';
+ };
+ };
+ in {
+ webserver = commonConfig;
+
+ newwebserver = { pkgs, lib, ... }: {
+ imports = [ commonConfig ];
+ services.nginx.virtualHosts.localhost = {
+ root = lib.mkForce (pkgs.runCommand "testdir2" {} ''
+ mkdir "$out"
+ echo hello world > "$out/index.html"
+ '');
+ };
+ };
};
- testScript = ''
- startAll;
+ testScript = { nodes, ... }: let
+ newServerSystem = nodes.newwebserver.config.system.build.toplevel;
+ switch = "${newServerSystem}/bin/switch-to-configuration test";
+ in ''
+ my $url = 'http://localhost/index.html';
+
+ sub checkEtag {
+ my $etag = $webserver->succeed(
+ 'curl -v '.$url.' 2>&1 | sed -n -e "s/^< [Ee][Tt][Aa][Gg]: *//p"'
+ );
+ $etag =~ s/\r?\n$//;
+ my $httpCode = $webserver->succeed(
+ 'curl -w "%{http_code}" -X HEAD -H \'If-None-Match: '.$etag.'\' '.$url
+ );
+ chomp $httpCode;
+ die "HTTP code is not 304" unless $httpCode == 304;
+ return $etag;
+ }
$webserver->waitForUnit("nginx");
$webserver->waitForOpenPort("80");
+
+ subtest "check ETag if serving Nix store paths", sub {
+ my $oldEtag = checkEtag;
+ $webserver->succeed('${switch}');
+ my $newEtag = checkEtag;
+ die "Old ETag $oldEtag is the same as $newEtag" if $oldEtag eq $newEtag;
+ };
'';
})