aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/networking.nix
diff options
context:
space:
mode:
authorUli Baum <xeji@cat3.de>2018-08-26 14:15:15 +0200
committerUli Baum <xeji@cat3.de>2018-08-26 14:15:15 +0200
commitf021702d212c6f78225fd2ed3a08d7ce669731f1 (patch)
tree3c2d0504c216023165939e40e9c23e2f6691c44c /nixos/tests/networking.nix
parent3d1331f438b536f65fa4f5a07cbcb9eaaae8ce2f (diff)
nixos/tests/networking: fix routes tests
The output format of `ip route` changed, it now explicitly shows "proto static" for static routes.
Diffstat (limited to 'nixos/tests/networking.nix')
-rw-r--r--nixos/tests/networking.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/tests/networking.nix b/nixos/tests/networking.nix
index cd5d537a3be7..76ece1ea3e6f 100644
--- a/nixos/tests/networking.nix
+++ b/nixos/tests/networking.nix
@@ -552,15 +552,15 @@ let
testScript = ''
my $targetIPv4Table = <<'END';
- 10.0.0.0/16 scope link mtu 1500
+ 10.0.0.0/16 proto static scope link mtu 1500
192.168.1.0/24 proto kernel scope link src 192.168.1.2
- 192.168.2.0/24 via 192.168.1.1
+ 192.168.2.0/24 via 192.168.1.1 proto static
END
my $targetIPv6Table = <<'END';
2001:1470:fffd:2097::/64 proto kernel metric 256 pref medium
- 2001:1470:fffd:2098::/64 via fdfd:b3f0::1 metric 1024 pref medium
- fdfd:b3f0::/48 metric 1024 pref medium
+ 2001:1470:fffd:2098::/64 via fdfd:b3f0::1 proto static metric 1024 pref medium
+ fdfd:b3f0::/48 proto static metric 1024 pref medium
END
$machine->start;