aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/mongodb.nix
diff options
context:
space:
mode:
authorPeter Woodman <peter@shortbus.org>2020-07-07 14:53:31 -0400
committerPeter Woodman <peter.woodman@mongodb.com>2020-07-24 11:44:16 -0400
commitdbd0f3e957e6327c736ae030d763368efb1c5254 (patch)
treeab606a373b16217853e72dc6cf81059eb200d598 /nixos/tests/mongodb.nix
parent1c26e6baecd8a71e4d41ff0eb3c81ce3c05136c3 (diff)
mongodb: 4.0.12 -> 4.2.8
Not strictly an upgrade, but adds a new mongodb-4_2 target with the current mongodb from that branch. Use matching client and server versions in mongodb tests- tests were using the mongo 3.4 client to connect, and this finally doesn't work with server 4.2. Per reviewer suggestion, adding myself as cheetah3 maintainer. Additionally, reestore comments describing the purpose of the build-dependencies patch
Diffstat (limited to 'nixos/tests/mongodb.nix')
-rw-r--r--nixos/tests/mongodb.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/tests/mongodb.nix b/nixos/tests/mongodb.nix
index a637ec4bfc00..453fb569e8c4 100644
--- a/nixos/tests/mongodb.nix
+++ b/nixos/tests/mongodb.nix
@@ -15,7 +15,7 @@ import ./make-test-python.nix ({ pkgs, ... }:
node.wait_for_open_port(27017)
assert "hello" in node.succeed(
- "mongo ${testQuery}"
+ "${pkg}/bin/mongo ${testQuery}"
)
node.execute(
@@ -36,6 +36,7 @@ import ./make-test-python.nix ({ pkgs, ... }:
mongodb-3_4
mongodb-3_6
mongodb-4_0
+ mongodb-4_2
];
};
};
@@ -46,6 +47,7 @@ import ./make-test-python.nix ({ pkgs, ... }:
+ runMongoDBTest pkgs.mongodb-3_4
+ runMongoDBTest pkgs.mongodb-3_6
+ runMongoDBTest pkgs.mongodb-4_0
+ + runMongoDBTest pkgs.mongodb-4_2
+ ''
node.shutdown()
'';