aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2018-03-14 20:36:35 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2018-03-21 23:19:26 +0200
commite58624a877342d1fea39b02a5d6528cd53eefefe (patch)
tree46a816c383d550417a7f801f6af07829712c1a52 /nixos/tests/installer.nix
parentf59eab75d2bb20e44aff84ccadf65e4024db6eb4 (diff)
nixos/tests: Make simpleUefiGrub test work on AArch64
Needs more refactoring for the AArch64 '-enable-kvm' stuff some day...
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index c12919540a30..f67011b4412c 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -69,11 +69,17 @@ let
let
iface = if grubVersion == 1 then "ide" else "virtio";
isEfi = bootLoader == "systemd-boot" || (bootLoader == "grub" && grubUseEfi);
+
+ # FIXME don't duplicate the -enable-kvm etc. flags here yet again!
qemuFlags =
(if system == "x86_64-linux" then "-m 768 " else "-m 512 ") +
- (optionalString (system == "x86_64-linux") "-cpu kvm64 ");
+ (optionalString (system == "x86_64-linux") "-cpu kvm64 ") +
+ (optionalString (system == "aarch64-linux") "-enable-kvm -machine virt,gic-version=host -cpu host ");
+
hdFlags = ''hda => "vm-state-machine/machine.qcow2", hdaInterface => "${iface}", ''
- + optionalString isEfi ''bios => "${pkgs.OVMF.fd}/FV/OVMF.fd", '';
+ + optionalString isEfi (if pkgs.stdenv.isAarch64
+ then ''bios => "${pkgs.OVMF.fd}/FV/QEMU_EFI.fd", ''
+ else ''bios => "${pkgs.OVMF.fd}/FV/OVMF.fd", '');
in
''
$machine->start;