aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2018-03-23 19:27:31 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2018-03-24 16:11:31 +0200
commit3131daace1eed2b642ab56c5843fd2057fbbfde3 (patch)
tree2887e1dd06d56dc2d82a25dd09acde9ca5938f8c /nixos/tests/installer.nix
parent902b3a161c6fcce873bd4e6a745119d7f6af6bf9 (diff)
nixos/tests/installer: Give eval failure on unsupported boot methods
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index f67011b4412c..acf248d0a5a6 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -80,8 +80,9 @@ let
+ optionalString isEfi (if pkgs.stdenv.isAarch64
then ''bios => "${pkgs.OVMF.fd}/FV/QEMU_EFI.fd", ''
else ''bios => "${pkgs.OVMF.fd}/FV/OVMF.fd", '');
- in
- ''
+ in if !isEfi && !(pkgs.stdenv.isi686 || pkgs.stdenv.isx86_64) then
+ throw "Non-EFI boot methods are only supported on i686 / x86_64"
+ else ''
$machine->start;
# Make sure that we get a login prompt etc.