aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authorSymphorien Gibol <symphorien+git@xlumurb.eu>2018-11-17 22:30:29 +0100
committerSymphorien Gibol <symphorien+git@xlumurb.eu>2018-11-17 22:30:29 +0100
commit2dbed7e726c81f20821bb8db4554834b0f74a6d4 (patch)
tree533991813fd365e7725a0551e9396a2d6e954f15 /nixos/tests/installer.nix
parent2d96b9a2942d2ba31756ab4142daeabc879d8d5d (diff)
nixos/tests/installer.nix: shorten test name to fit length limit
previously one of the tests would fail with boot-after-install: starting vm Path length (109) is longer than maximum supported length (108) and will be truncated at /nix/store/0ingn8cwwnl84i374hcl6nafsm2c5m2p-perl-5.28.0/lib/perl5/5.28.0/x86_64-linux-thread-multi/Socket.pm line 872, <__ANONIO__> line 268. boot-after-install# qemu-system-x86_64: -monitor unix:./monitor: Failed to connect socket ./monitor: No such file or directory error: QEMU died prematurely QEMU died prematurely vde_switch: EOF on stdin, cleaning up and exiting cleaning up builder for '/nix/store/zbpxwwxwy7f6z5z3kg4nf5mjqsywzjvx-vm-test-run-installer-filesystemEncryptedWithKeyfile.drv' failed with exit code 4 Shortening the test name fixes the issue.
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index e03fc459cb87..c8edaaba1585 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -481,7 +481,7 @@ in {
# Test whether opening encrypted filesystem with keyfile
# Checks for regression of missing cryptsetup, when no luks device without
# keyfile is configured
- filesystemEncryptedWithKeyfile = makeInstallerTest "filesystemEncryptedWithKeyfile"
+ encryptedFSWithKeyfile = makeInstallerTest "encryptedFSWithKeyfile"
{ createPartitions = ''
$machine->succeed(
"flock /dev/vda parted --script /dev/vda -- mklabel msdos"