aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/gnome3.nix
diff options
context:
space:
mode:
authorMathnerd314 <mathnerd314.gph+github@gmail.com>2015-10-05 22:10:40 -0600
committerMathnerd314 <mathnerd314.gph+github@gmail.com>2015-10-05 22:10:40 -0600
commitfaa82a676bd442b95703647cf4cc6c693d0dca67 (patch)
treee7039f8038365f7bec1781de111da5abab53a2d0 /nixos/tests/gnome3.nix
parentbcf536ff3fb6338caeb92c4fce0c7053599aeb91 (diff)
gnome3 test: increase timeout
The gnome3 test has been failing recently ([1](http://hydra.nixos.org/build/26608126/nixlog/1/raw) [2](http://hydra.nixos.org/build/26605926/nixlog/1/raw)); this is due to exit code 124 which is [the command timing out](https://www.gnu.org/software/coreutils/manual/html_node/timeout-invocation.html). This increases the timeout to 900, to align with the similar timeout in https://github.com/NixOS/nixpkgs/blob/master/nixos/lib/test-driver/Machine.pm#L222
Diffstat (limited to 'nixos/tests/gnome3.nix')
-rw-r--r--nixos/tests/gnome3.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/gnome3.nix b/nixos/tests/gnome3.nix
index 7662efe1b350..714b35503706 100644
--- a/nixos/tests/gnome3.nix
+++ b/nixos/tests/gnome3.nix
@@ -28,7 +28,7 @@ import ./make-test.nix ({ pkgs, ...} : {
$machine->succeed("su - alice -c 'DISPLAY=:0.0 gnome-terminal &'");
$machine->waitForWindow(qr/Terminal/);
- $machine->mustSucceed("timeout 60 bash -c 'journalctl -f|grep -m 1 \"GNOME Shell started\"'");
+ $machine->mustSucceed("timeout 900 bash -c 'journalctl -f|grep -m 1 \"GNOME Shell started\"'");
$machine->sleep(10);
$machine->screenshot("screen");
'';