aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/containers-physical_interfaces.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2017-12-03 05:14:54 +0100
committerrnhmjoj <rnhmjoj@inventati.org>2018-02-17 14:57:07 +0100
commite239c1e5820bdbb3d94ccc46e2d6756b0d37057d (patch)
tree949c07008657835d1ac6d6b247a50d05d7152cae /nixos/tests/containers-physical_interfaces.nix
parentc1bed05e341756f7fdfa73035c7f1e078e49be3d (diff)
nixos/tests: rename IP addresses/routes options
Diffstat (limited to 'nixos/tests/containers-physical_interfaces.nix')
-rw-r--r--nixos/tests/containers-physical_interfaces.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/nixos/tests/containers-physical_interfaces.nix b/nixos/tests/containers-physical_interfaces.nix
index a3b0b29951bf..bd1228b8e37d 100644
--- a/nixos/tests/containers-physical_interfaces.nix
+++ b/nixos/tests/containers-physical_interfaces.nix
@@ -16,9 +16,9 @@ import ./make-test.nix ({ pkgs, ...} : {
interfaces = [ "eth1" ];
config = {
- networking.interfaces.eth1 = {
- ip4 = [ { address = "10.10.0.1"; prefixLength = 24; } ];
- };
+ networking.interfaces.eth1.ipv4.addresses = [
+ { address = "10.10.0.1"; prefixLength = 24; }
+ ];
networking.firewall.enable = false;
};
};
@@ -33,9 +33,9 @@ import ./make-test.nix ({ pkgs, ...} : {
config = {
networking.bridges.br0.interfaces = [ "eth1" ];
- networking.interfaces.br0 = {
- ip4 = [ { address = "10.10.0.2"; prefixLength = 24; } ];
- };
+ networking.interfaces.br0.ipv4.addresses = [
+ { address = "10.10.0.2"; prefixLength = 24; }
+ ];
networking.firewall.enable = false;
};
};
@@ -54,9 +54,9 @@ import ./make-test.nix ({ pkgs, ...} : {
interfaces = [ "eth1" ];
mode = "active-backup";
};
- networking.interfaces.bond0 = {
- ip4 = [ { address = "10.10.0.3"; prefixLength = 24; } ];
- };
+ networking.interfaces.bond0.ipv4.addresses = [
+ { address = "10.10.0.3"; prefixLength = 24; }
+ ];
networking.firewall.enable = false;
};
};
@@ -76,9 +76,9 @@ import ./make-test.nix ({ pkgs, ...} : {
mode = "active-backup";
};
networking.bridges.br0.interfaces = [ "bond0" ];
- networking.interfaces.br0 = {
- ip4 = [ { address = "10.10.0.4"; prefixLength = 24; } ];
- };
+ networking.interfaces.br0.ipv4.addresses = [
+ { address = "10.10.0.4"; prefixLength = 24; }
+ ];
networking.firewall.enable = false;
};
};