aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/chromium.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-03-21 03:50:38 +0100
committeraszlig <aszlig@redmoonstudios.org>2016-03-21 03:50:38 +0100
commite047d792796165c369ea2640e997e641b4908146 (patch)
treeb6096917b0c155abfa627c663c20d749597f9e6c /nixos/tests/chromium.nix
parent5ebd629c6ff6ed00bcc3fff056dc9c2ed3dc848e (diff)
nixos/tests/chromium: Propagate "system" to pkgs
Assigning the channelMap by the function attrset argument at the top-level of the test expression file may reference a different architecture than we need for the tests. So if we get the pkgs attribute by auto-calling, this will lead to test failure because we have a different architecture for the test than for the browser. Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/tests/chromium.nix')
-rw-r--r--nixos/tests/chromium.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/chromium.nix b/nixos/tests/chromium.nix
index dfa65ab73912..9a6414f81c39 100644
--- a/nixos/tests/chromium.nix
+++ b/nixos/tests/chromium.nix
@@ -1,5 +1,5 @@
{ system ? builtins.currentSystem
-, pkgs ? import ../.. {}
+, pkgs ? import ../.. { inherit system; }
, channelMap ? {
stable = pkgs.chromium;
beta = pkgs.chromiumBeta;