aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/chromium.nix
diff options
context:
space:
mode:
authorGabriel Ebner <gebner@gebner.org>2015-09-12 12:12:57 +0200
committerGabriel Ebner <gebner@gebner.org>2015-09-12 13:18:31 +0200
commit50b1ca6dcc5685bc556d4161d4d785f07c4a54d6 (patch)
tree404d1d2d81c24fd4b1540af1236d97f92f58124c /nixos/tests/chromium.nix
parent09a08ef16421ae00d6e8d1ca9418437528b61a4e (diff)
xdotool: 2.20110530.1 -> 3.20150503.1
Diffstat (limited to 'nixos/tests/chromium.nix')
-rw-r--r--nixos/tests/chromium.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/tests/chromium.nix b/nixos/tests/chromium.nix
index 3624131b364e..213dd4ca43b3 100644
--- a/nixos/tests/chromium.nix
+++ b/nixos/tests/chromium.nix
@@ -44,6 +44,8 @@ import ./make-test.nix (
search --onlyvisible --name "startup done"
windowfocus --sync
windowactivate --sync
+ ''}");
+ $machine->execute("${xdo "new-window" ''
key Ctrl+n
''}");
});
@@ -55,6 +57,8 @@ import ./make-test.nix (
search --onlyvisible --name "new tab"
windowfocus --sync
windowactivate --sync
+ ''}");
+ $machine->execute("${xdo "close-window" ''
key Ctrl+w
''}");
for (1..20) {
@@ -155,6 +159,8 @@ import ./make-test.nix (
$machine->succeed("${xdo "submit-url" ''
search --sync --onlyvisible --name "sandbox status"
windowfocus --sync
+ ''}");
+ $machine->succeed("${xdo "submit-url" ''
key --delay 1000 Ctrl+a Ctrl+c
''}");