aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/acme.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2017-09-14 23:18:52 +0200
committeraszlig <aszlig@redmoonstudios.org>2017-09-14 23:18:52 +0200
commitb5fbb4f3622bc6edabe59402aeb9cd4a40cf08f3 (patch)
treefe5410a2a2425270690bda7bd89d280a0c3960f6 /nixos/tests/acme.nix
parentd1260ea6aaa63dae88029fa6597d182fee969b90 (diff)
nixos/tests/acme: Use overridePythonAttrs
Quoting from @FRidh: Note overridePythonAttrs exists since 17.09. It overrides the call to buildPythonPackage. While it's not strictly necessary to do this, because postPatch ends up in drvAttrs anyway, it's probably better to use overridePythonAttrs so we don't run into problems when the underlying implementation of buildPythonPackage changes. Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/tests/acme.nix')
-rw-r--r--nixos/tests/acme.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/tests/acme.nix b/nixos/tests/acme.nix
index f44524a1d6a8..d7452744e17b 100644
--- a/nixos/tests/acme.nix
+++ b/nixos/tests/acme.nix
@@ -14,8 +14,8 @@ let
pythonPackages = (super.python.override {
packageOverrides = lib.const (pysuper: {
- certifi = pysuper.certifi.overrideDerivation (drv: {
- postPatch = (drv.postPatch or "") + ''
+ certifi = pysuper.certifi.overridePythonAttrs (attrs: {
+ postPatch = (attrs.postPatch or "") + ''
cat "${self.cacert}/etc/ssl/certs/ca-bundle.crt" \
> certifi/cacert.pem
'';