aboutsummaryrefslogtreecommitdiff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2020-02-12 22:43:35 +0100
committerEelco Dolstra <edolstra@gmail.com>2020-02-12 22:44:59 +0100
commit3182fbdeaae38dd20c1420a23a2c5f99566f280f (patch)
tree5f075b0d8a34332a9eaf8ceaa87f173a0ba73d76 /nixos/release.nix
parentaf7b000928f309492b61c200e0f935ae2794dc1c (diff)
nixos/release.nix: Import './..' instead of nixpkgs
'nixpkgs' is a result of a call to cleanSource, which is very expensive and fails in --dry-run mode.
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index 512ba7143977..6107f3529715 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -20,7 +20,7 @@ let
allTestsForSystem = system:
import ./tests/all-tests.nix {
inherit system;
- pkgs = import nixpkgs { inherit system; };
+ pkgs = import ./.. { inherit system; };
callTest = t: {
${system} = hydraJob t.test;
};
@@ -28,7 +28,7 @@ let
allTests =
foldAttrs recursiveUpdate {} (map allTestsForSystem supportedSystems);
- pkgs = import nixpkgs { system = "x86_64-linux"; };
+ pkgs = import ./.. { system = "x86_64-linux"; };
versionModule =
@@ -41,7 +41,7 @@ let
makeIso =
{ module, type, system, ... }:
- with import nixpkgs { inherit system; };
+ with import ./.. { inherit system; };
hydraJob ((import lib/eval-config.nix {
inherit system;
@@ -54,7 +54,7 @@ let
makeSdImage =
{ module, system, ... }:
- with import nixpkgs { inherit system; };
+ with import ./.. { inherit system; };
hydraJob ((import lib/eval-config.nix {
inherit system;
@@ -65,7 +65,7 @@ let
makeSystemTarball =
{ module, maintainers ? ["viric"], system }:
- with import nixpkgs { inherit system; };
+ with import ./.. { inherit system; };
let
@@ -188,7 +188,7 @@ in rec {
# A bootable VirtualBox virtual appliance as an OVA file (i.e. packaged OVF).
ova = forMatchingSystems [ "x86_64-linux" ] (system:
- with import nixpkgs { inherit system; };
+ with import ./.. { inherit system; };
hydraJob ((import lib/eval-config.nix {
inherit system;
@@ -204,7 +204,7 @@ in rec {
# A disk image that can be imported to Amazon EC2 and registered as an AMI
amazonImage = forMatchingSystems [ "x86_64-linux" "aarch64-linux" ] (system:
- with import nixpkgs { inherit system; };
+ with import ./.. { inherit system; };
hydraJob ((import lib/eval-config.nix {
inherit system;