aboutsummaryrefslogtreecommitdiff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorSamuel Dionne-Riel <samuel@dionne-riel.com>2018-12-25 18:58:04 -0500
committerDomen Kožar <domen@enlambda.com>2018-12-26 11:03:32 +0000
commit302d53df2b79f48ea6e9f42e47dd17e561ff6433 (patch)
tree88371734224d440bd3175ae3ed5801d209658073 /nixos/release.nix
parent207210660f2a8f178fa0dfb3fd3c35371bf9406d (diff)
nixos/sd-image-aarch64-new-kernel: Added to release
This, paired with the previous commit, ensures the channel won't be held back from a kernel upgrade and a non-building sd image, while still having a new-kernel variant available.
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index e7952b33de6b..df2c52ccd0b6 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -172,6 +172,14 @@ in rec {
inherit system;
});
+ sd_image_new_kernel = forMatchingSystems [ "aarch64-linux" ] (system: makeSdImage {
+ module = {
+ aarch64-linux = ./modules/installer/cd-dvd/sd-image-aarch64-new-kernel.nix;
+ }.${system};
+ type = "minimal-new-kernel";
+ inherit system;
+ });
+
# A bootable VirtualBox virtual appliance as an OVA file (i.e. packaged OVF).
ova = forMatchingSystems [ "x86_64-linux" ] (system: