aboutsummaryrefslogtreecommitdiff
path: root/nixos/release-combined.nix
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2017-08-03 08:09:30 -0400
committerRobin Gloster <mail@glob.in>2017-08-05 12:06:05 +0200
commit7d0b001d4a5653ce87f6e10475fba8e3c55d2af8 (patch)
treeb5b37a952d3e53885ca2cd8c9afd7d7b729b47f3 /nixos/release-combined.nix
parenteb7312ca7d00cd4d8d424b8f79e1c37c1b4991bf (diff)
nixos,nixpkgs: only build essentials on i686
Diffstat (limited to 'nixos/release-combined.nix')
-rw-r--r--nixos/release-combined.nix22
1 files changed, 16 insertions, 6 deletions
diff --git a/nixos/release-combined.nix b/nixos/release-combined.nix
index ecbd317cb9a4..26e689a7c92d 100644
--- a/nixos/release-combined.nix
+++ b/nixos/release-combined.nix
@@ -4,7 +4,8 @@
{ nixpkgs ? { outPath = ./..; revCount = 56789; shortRev = "gfedcba"; }
, stableBranch ? false
-, supportedSystems ? [ "x86_64-linux" "i686-linux" ]
+, supportedSystems ? [ "x86_64-linux" ]
+, limitedSupportedSystems ? [ "i686-linux" ]
}:
let
@@ -19,10 +20,16 @@ let
else pkgs.lib.mapAttrs (n: v: removeMaintainers v) set
else set;
+ allSupportedNixpkgs = builtins.removeAttrs (removeMaintainers (import ../pkgs/top-level/release.nix {
+ supportedSystems = supportedSystems ++ limitedSupportedSystems;
+ nixpkgs = nixpkgsSrc;
+ })) [ "unstable" ];
+
in rec {
nixos = removeMaintainers (import ./release.nix {
- inherit stableBranch supportedSystems;
+ inherit stableBranch;
+ supportedSystems = supportedSystems ++ limitedSupportedSystems;
nixpkgs = nixpkgsSrc;
});
@@ -38,8 +45,11 @@ in rec {
maintainers = [ pkgs.lib.maintainers.eelco ];
};
constituents =
- let all = x: map (system: x.${system}) supportedSystems; in
- [ nixos.channel
+ let
+ all = x: map (system: x.${system})
+ (supportedSystems ++ limitedSupportedSystems);
+ in [
+ nixos.channel
(all nixos.dummy)
(all nixos.manual)
@@ -106,8 +116,8 @@ in rec {
(all nixos.tests.xfce)
nixpkgs.tarball
- (all nixpkgs.emacs)
- (all nixpkgs.jdk)
+ (all allSupportedNixpkgs.emacs)
+ (all allSupportedNixpkgs.jdk)
];
});