aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/tasks/network-interfaces.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2019-08-08 22:48:27 +0200
committerSilvan Mosberger <infinisil@icloud.com>2019-08-31 18:19:00 +0200
commit478e7184f88db1364cc75107036f7c4decc0cc41 (patch)
tree5ff3d3a18e3aef9af4333c392a94751333754270 /nixos/modules/tasks/network-interfaces.nix
parent69d58ee24506e2b3b5aff347ae3b0791110340ec (diff)
nixos/modules: Remove all usages of types.string
And replace them with a more appropriate type Also fix up some minor module problems along the way
Diffstat (limited to '')
-rw-r--r--nixos/modules/tasks/network-interfaces.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/tasks/network-interfaces.nix b/nixos/modules/tasks/network-interfaces.nix
index 5ac753c92a78..16dde9175150 100644
--- a/nixos/modules/tasks/network-interfaces.nix
+++ b/nixos/modules/tasks/network-interfaces.nix
@@ -836,7 +836,7 @@ in
options = {
device = mkOption {
- type = types.string;
+ type = types.str;
example = "wlp6s0";
description = "The name of the underlying hardware WLAN device as assigned by <literal>udev</literal>.";
};
@@ -852,7 +852,7 @@ in
};
meshID = mkOption {
- type = types.nullOr types.string;
+ type = types.nullOr types.str;
default = null;
description = "MeshID of interface with type <literal>mesh</literal>.";
};