aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorBen Wolsieffer <benwolsieffer@gmail.com>2020-07-11 17:24:59 -0400
committerBen Wolsieffer <benwolsieffer@gmail.com>2020-07-11 17:24:59 -0400
commitab5faea41ef2ee8a2e0ad65dd6054bb316db6e17 (patch)
treed5a6bd51a089de1c958596626abdb7d87d9b0ed2 /nixos/modules/system/boot/stage-1.nix
parent8d05772134f17180fb2711d0660702dae2a67313 (diff)
nixos/stage-1: fix initrd secrets with custom compressor
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index d551466f52eb..3e43de9e6d87 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -374,7 +374,8 @@ let
) config.boot.initrd.secrets)
}
- (cd "$tmp" && find . | cpio -H newc -o) | gzip >>"$1"
+ (cd "$tmp" && find . -print0 | sort -z | cpio -o -H newc -R +0:+0 --reproducible --null) | \
+ ${config.boot.initrd.compressor} >> "$1"
'';
in