aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2019-01-17 07:42:32 +0000
committerGitHub <noreply@github.com>2019-01-17 07:42:32 +0000
commita6b97bd1bbce75b0a6a2baa83126b603696e500e (patch)
tree4a1dfed1cfa17287aa8c69d1d55556de5983519c /nixos/modules/system/boot/stage-1.nix
parentc052da08dcb3235ee0e3f7c353fc9a664b12dbef (diff)
parent62d21f251194ba93541239adc22afd0fb4f38f71 (diff)
Merge pull request #42183 from kisik21/master
nixos/stage-1, nixos/f2fs: added F2FS resizing
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index e7167999a6f8..c8ea1401528c 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -127,8 +127,8 @@ let
copy_bin_and_libs ${pkgs.kmod}/bin/kmod
ln -sf kmod $out/bin/modprobe
- # Copy resize2fs if needed.
- ${optionalString (any (fs: fs.autoResize) fileSystems) ''
+ # Copy resize2fs if any ext* filesystems are to be resized
+ ${optionalString (any (fs: fs.autoResize && (lib.hasPrefix "ext" fs.fsType)) fileSystems) ''
# We need mke2fs in the initrd.
copy_bin_and_libs ${pkgs.e2fsprogs}/sbin/resize2fs
''}