aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2020-08-24 12:42:24 +0200
committerGitHub <noreply@github.com>2020-08-24 12:42:24 +0200
commit40d2968ebf3b2b4c547caaa776b6eb875e1e5f83 (patch)
treee162a8e316931cc8eab5f0123dcbe76f24b21eea /nixos/modules/system/boot/stage-1.nix
parent6d122d67fa3ae31f36405ecad6bf0cbfc156ed79 (diff)
parent618e273861f7eda1f04fd8909cbe066e75556070 (diff)
Merge pull request #94354 from flokli/systemd-246
systemd: 245.6 -> 246
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index a04660fb56e7..ec5eadf69c3f 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -119,12 +119,13 @@ let
copy_bin_and_libs ${pkgs.mdadm}/sbin/mdmon
# Copy udev.
- copy_bin_and_libs ${udev}/lib/systemd/systemd-udevd
- copy_bin_and_libs ${udev}/lib/systemd/systemd-sysctl
copy_bin_and_libs ${udev}/bin/udevadm
+ copy_bin_and_libs ${udev}/lib/systemd/systemd-sysctl
for BIN in ${udev}/lib/udev/*_id; do
copy_bin_and_libs $BIN
done
+ # systemd-udevd is only a symlink to udevadm these days
+ ln -sf udevadm $out/bin/systemd-udevd
# Copy modprobe.
copy_bin_and_libs ${pkgs.kmod}/bin/kmod