aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authordanbst <abcz2.uprola@gmail.com>2019-01-26 21:44:05 +0200
committerdanbst <abcz2.uprola@gmail.com>2019-01-31 00:41:10 +0200
commit27982b408e465554b8831f492362bc87ed0ec02a (patch)
tree9d91ef0747a5e1ed4a425e3e86a1b7172a8a16e4 /nixos/modules/system/boot/stage-1.nix
parentaa2e63ce5ed6e24d73eaefe61489ece46f7460d7 (diff)
types.optionSet: deprecate and remove last usages
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix22
1 files changed, 12 insertions, 10 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index c8ea1401528c..5e27b24ac447 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -525,16 +525,18 @@ in
};
fileSystems = mkOption {
- options.neededForBoot = mkOption {
- default = false;
- type = types.bool;
- description = ''
- If set, this file system will be mounted in the initial
- ramdisk. By default, this applies to the root file system
- and to the file system containing
- <filename>/nix/store</filename>.
- '';
- };
+ type = with lib.types; loaOf (submodule {
+ options.neededForBoot = mkOption {
+ default = false;
+ type = types.bool;
+ description = ''
+ If set, this file system will be mounted in the initial
+ ramdisk. By default, this applies to the root file system
+ and to the file system containing
+ <filename>/nix/store</filename>.
+ '';
+ };
+ });
};
};