aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/services/networking/amuled.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-10 13:28:20 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-10 13:28:20 +0200
commit5c1f8cbc70cd5e6867ef6a2a06d27a40daa07010 (patch)
treea6c0f605be6de3f372ae69905b331f9f75452da7 /nixos/modules/services/networking/amuled.nix
parent6070bc016bd2fd945b04347e25cfd3738622d2ac (diff)
Move all of NixOS to nixos/ in preparation of the repository merge
Diffstat (limited to 'nixos/modules/services/networking/amuled.nix')
-rw-r--r--nixos/modules/services/networking/amuled.nix78
1 files changed, 78 insertions, 0 deletions
diff --git a/nixos/modules/services/networking/amuled.nix b/nixos/modules/services/networking/amuled.nix
new file mode 100644
index 000000000000..8652d0daf4c8
--- /dev/null
+++ b/nixos/modules/services/networking/amuled.nix
@@ -0,0 +1,78 @@
+{ config, pkgs, ... }:
+
+with pkgs.lib;
+
+let
+ cfg = config.services.amule;
+ user = if cfg.user != null then cfg.user else "amule";
+in
+
+{
+
+ ###### interface
+
+ options = {
+
+ services.amule = {
+
+ enable = mkOption {
+ default = false;
+ description = ''
+ Whether to run the AMule daemon. You need to manually run "amuled --ec-config" to configure the service for the first time.
+ '';
+ };
+
+ dataDir = mkOption {
+ default = ''/home/${user}/'';
+ description = ''
+ The directory holding configuration, incoming and temporary files.
+ '';
+ };
+
+ user = mkOption {
+ default = null;
+ description = ''
+ The user the AMule daemon should run as.
+ '';
+ };
+
+ };
+
+ };
+
+
+ ###### implementation
+
+ config = mkIf cfg.enable {
+
+ users.extraUsers = mkIf (cfg.user == null) [
+ { name = "amule";
+ description = "AMule daemon";
+ group = "amule";
+ uid = config.ids.uids.amule;
+ } ];
+
+ users.extraGroups = mkIf (cfg.user == null) [
+ { name = "amule";
+ gid = config.ids.gids.amule;
+ } ];
+
+ jobs.amuled =
+ { description = "AMule daemon";
+
+ startOn = "ip-up";
+
+ preStart = ''
+ mkdir -p ${cfg.dataDir}
+ chown ${user} ${cfg.dataDir}
+ '';
+
+ exec = ''
+ ${pkgs.su}/bin/su -s ${pkgs.stdenv.shell} ${user} \
+ -c 'HOME="${cfg.dataDir}" ${pkgs.amuleDaemon}/bin/amuled'
+ '';
+ };
+
+ };
+
+}