aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/services/hardware/udev.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-10-03 20:52:03 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-10-04 10:03:53 +0200
commitb44d846990d779f7201f114076a2f2bcacdc91c5 (patch)
tree9a6f766bfb04765e1095be811aab38b94f88bd5d /nixos/modules/services/hardware/udev.nix
parentec7a4ddd92e19e0084a07448671cd79d974cd818 (diff)
udev: complete rework
- systemd puts all into one output now (except for man), because I wasn't able to fix all systemd/udev refernces for NixOS to work well - libudev is now by default *copied* into another path, which is what most packages will use as build input :-) - pkgs.udev = [ libudev.out libudev.dev ]; because there are too many references that just put `udev` into build inputs (to rewrite them all), also this made "${udev}/foo" fail at *evaluation* time so it's easier to catch and change to something more specific
Diffstat (limited to '')
-rw-r--r--nixos/modules/services/hardware/udev.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/hardware/udev.nix b/nixos/modules/services/hardware/udev.nix
index 7ff13af15926..107e1012b88d 100644
--- a/nixos/modules/services/hardware/udev.nix
+++ b/nixos/modules/services/hardware/udev.nix
@@ -58,13 +58,13 @@ let
--replace \"/bin/mount \"${pkgs.utillinux}/bin/mount
done
- echo -n "Checking that all programs called by relative paths in udev rules exist in ${pkgs.udev.out}/lib/udev... "
+ echo -n "Checking that all programs called by relative paths in udev rules exist in ${udev}/lib/udev... "
import_progs=$(grep 'IMPORT{program}="[^/$]' $out/* |
sed -e 's/.*IMPORT{program}="\([^ "]*\)[ "].*/\1/' | uniq)
run_progs=$(grep -v '^[[:space:]]*#' $out/* | grep 'RUN+="[^/$]' |
sed -e 's/.*RUN+="\([^ "]*\)[ "].*/\1/' | uniq)
for i in $import_progs $run_progs; do
- if [[ ! -x ${pkgs.udev.out}/lib/udev/$i && ! $i =~ socket:.* ]]; then
+ if [[ ! -x ${udev}/lib/udev/$i && ! $i =~ socket:.* ]]; then
echo "FAIL"
echo "$i is called in udev rules but not installed by udev"
exit 1