aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/services/hardware/udev.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2016-08-15 19:05:52 -0400
committerShea Levy <shea@shealevy.com>2016-08-15 19:05:52 -0400
commit9adad8612b082bcbae30c81678a04b79a44079a4 (patch)
tree6814d056ee2960d122842dc9c830bb411c40d5ff /nixos/modules/services/hardware/udev.nix
parent57b2d1e9b0dcdd1d25bd2d450174764b9417ffc1 (diff)
Revert "Merge branch 'modprobe-fix' of git://github.com/abbradar/nixpkgs"
Was meant to go into staging, sorry This reverts commit 57b2d1e9b0dcdd1d25bd2d450174764b9417ffc1, reversing changes made to 760b2b9048ea775c319cb348d74447a20dea513e.
Diffstat (limited to '')
-rw-r--r--nixos/modules/services/hardware/udev.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/services/hardware/udev.nix b/nixos/modules/services/hardware/udev.nix
index 7c4c93d0fcb3..e7741083d1ae 100644
--- a/nixos/modules/services/hardware/udev.nix
+++ b/nixos/modules/services/hardware/udev.nix
@@ -58,7 +58,7 @@ let
# Fix some paths in the standard udev rules. Hacky.
for i in $out/*.rules; do
substituteInPlace $i \
- --replace \"/sbin/modprobe \"${pkgs.kmod}/bin/modprobe \
+ --replace \"/sbin/modprobe \"${config.system.sbin.modprobe}/sbin/modprobe \
--replace \"/sbin/mdadm \"${pkgs.mdadm}/sbin/mdadm \
--replace \"/sbin/blkid \"${pkgs.utillinux}/sbin/blkid \
--replace \"/bin/mount \"${pkgs.utillinux}/bin/mount \
@@ -316,7 +316,8 @@ in
'';
systemd.services.systemd-udevd =
- { restartTriggers = cfg.packages;
+ { environment.MODULE_DIR = "/run/booted-system/kernel-modules/lib/modules";
+ restartTriggers = cfg.packages;
};
};