aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorChristian Kauhaus <kc@flyingcircus.io>2019-11-24 14:03:29 +0100
committerChristian Kauhaus <kc@flyingcircus.io>2019-11-24 14:03:29 +0100
commit3ea442ca94d91afd355dbdadece457ecb1ff9276 (patch)
treec28e45ede73bbc129ade0bc33d95be6763eac686 /nixos/modules/rename.nix
parent2dfa46efa1f9869aea98612efbd93d1181e9f080 (diff)
networking.vpnc: remove option
This PR is part of the networking.* namespace cleanup. The Cisco VPN module is currently of limited value since it just creates config files but does not manage services. The same functionality can be achieved by using _environment.etc_ instead. It would be a different situation if we had a full service module. So if you are annoyed by this change, please consider write a more featureful module and put its options unter _services.networking.vpnc_. Note that this change removes options for *Cisco VPN*, not *networkmanager-vpn*.
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index 7d8cf55b827a..a109b26a5f3d 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -235,6 +235,7 @@ with lib;
(mkRemovedOptionModule [ "services" "zabbixServer" "dbPassword" ] "Use services.zabbixServer.database.passwordFile instead.")
(mkRemovedOptionModule [ "systemd" "generator-packages" ] "Use systemd.packages instead.")
(mkRemovedOptionModule [ "fonts" "enableCoreFonts" ] "Use fonts.fonts = [ pkgs.corefonts ]; instead.")
+ (mkRemovedOptionModule [ "networking" "vpnc" ] "Use environment.etc.\"vpnc/service.conf\" instead.")
# ZSH
(mkRenamedOptionModule [ "programs" "zsh" "enableSyntaxHighlighting" ] [ "programs" "zsh" "syntaxHighlighting" "enable" ])