aboutsummaryrefslogtreecommitdiff
path: root/nixos/lib/make-system-tarball.nix
diff options
context:
space:
mode:
authorJaka Hudoklin <jakahudoklin@gmail.com>2014-12-11 22:54:46 +0100
committerJaka Hudoklin <jakahudoklin@gmail.com>2014-12-11 23:17:27 +0100
commita782b890d53b5c8a336677bb7c5394f9afb4c39b (patch)
tree76076370a6669a1ec991af3df03e0e3fcbc30d34 /nixos/lib/make-system-tarball.nix
parent747488ae66f9fd5d11c09f29e24b8dde636ba084 (diff)
nixos/make-system-tarball: extra commands to be executed before archive
Diffstat (limited to 'nixos/lib/make-system-tarball.nix')
-rw-r--r--nixos/lib/make-system-tarball.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/lib/make-system-tarball.nix b/nixos/lib/make-system-tarball.nix
index 3bd891fdbc2b..a2a0340a6bd3 100644
--- a/nixos/lib/make-system-tarball.nix
+++ b/nixos/lib/make-system-tarball.nix
@@ -16,6 +16,9 @@
# symlink to `object' that will be added to the tarball.
storeContents ? []
+ # Extra commands to be executed before archiving files
+, extraCommands ? ""
+
# Extra tar arguments
, extraArgs ? ""
}:
@@ -25,7 +28,7 @@ stdenv.mkDerivation {
builder = ./make-system-tarball.sh;
buildInputs = [perl xz];
- inherit fileName pathsFromGraph extraArgs;
+ inherit fileName pathsFromGraph extraArgs extraCommands;
# !!! should use XML.
sources = map (x: x.source) contents;