aboutsummaryrefslogtreecommitdiff
path: root/nixos/lib/make-system-tarball.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-10 13:28:20 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-10 13:28:20 +0200
commit5c1f8cbc70cd5e6867ef6a2a06d27a40daa07010 (patch)
treea6c0f605be6de3f372ae69905b331f9f75452da7 /nixos/lib/make-system-tarball.nix
parent6070bc016bd2fd945b04347e25cfd3738622d2ac (diff)
Move all of NixOS to nixos/ in preparation of the repository merge
Diffstat (limited to 'nixos/lib/make-system-tarball.nix')
-rw-r--r--nixos/lib/make-system-tarball.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/nixos/lib/make-system-tarball.nix b/nixos/lib/make-system-tarball.nix
new file mode 100644
index 000000000000..8fed9a348827
--- /dev/null
+++ b/nixos/lib/make-system-tarball.nix
@@ -0,0 +1,38 @@
+{ stdenv, perl, xz, pathsFromGraph
+
+, # The file name of the resulting tarball
+ fileName ? "nixos-system-${stdenv.system}"
+
+, # The files and directories to be placed in the tarball.
+ # This is a list of attribute sets {source, target} where `source'
+ # is the file system object (regular file or directory) to be
+ # grafted in the file system at path `target'.
+ contents
+
+, # In addition to `contents', the closure of the store paths listed
+ # in `packages' are also placed in the Nix store of the tarball. This is
+ # a list of attribute sets {object, symlink} where `object' if a
+ # store path whose closure will be copied, and `symlink' is a
+ # symlink to `object' that will be added to the tarball.
+ storeContents ? []
+}:
+
+stdenv.mkDerivation {
+ name = "tarball";
+ builder = ./make-system-tarball.sh;
+ buildInputs = [perl xz];
+
+ inherit fileName pathsFromGraph;
+
+ # !!! should use XML.
+ sources = map (x: x.source) contents;
+ targets = map (x: x.target) contents;
+
+ # !!! should use XML.
+ objects = map (x: x.object) storeContents;
+ symlinks = map (x: x.symlink) storeContents;
+
+ # For obtaining the closure of `storeContents'.
+ exportReferencesGraph =
+ map (x: [("closure-" + baseNameOf x.object) x.object]) storeContents;
+}