aboutsummaryrefslogtreecommitdiff
path: root/nixos/lib/make-disk-image.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-03-15 13:34:41 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-03-15 14:15:12 +0100
commit5cc7bcda3023b01bd926eccd0c5f095a050c5ab0 (patch)
treee8c235650551ca5bd2df714b090aa5ad297c1951 /nixos/lib/make-disk-image.nix
parent84f33c6edccae85d419639010fba9f6c7c8c7dfd (diff)
Combine OVA generation steps
Previously this was done in three derivations (one to build the raw disk image, one to convert to OVA, one to add a hydra-build-products file). Now it's done in one step to reduce the amount of copying to/from S3. In particular, not uploading the raw disk image prevents us from hitting hydra-queue-runner's size limit of 2 GiB.
Diffstat (limited to 'nixos/lib/make-disk-image.nix')
-rw-r--r--nixos/lib/make-disk-image.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/lib/make-disk-image.nix b/nixos/lib/make-disk-image.nix
index 62728c8ac761..7387bf147385 100644
--- a/nixos/lib/make-disk-image.nix
+++ b/nixos/lib/make-disk-image.nix
@@ -22,12 +22,13 @@
, # Shell code executed after the VM has finished.
postVM ? ""
+, name ? "nixos-disk-image"
}:
with lib;
pkgs.vmTools.runInLinuxVM (
- pkgs.runCommand "nixos-disk-image"
+ pkgs.runCommand name
{ preVM =
''
mkdir $out